Go Down

Topic: Empezando y problemas, como no (Read 2468 times) previous topic - next topic

algec

He empezado hoy con arduino y ya me surje el primer problema.
El puerto COM me cambia cuando quiere y se me cierra, con lo que no se porque no consigo que tras compilar mandar el programa al arduino, solo a veces, despues de reiniciar. Unas veces me coje el puerto 5 otras el 6 y hasta el Com7.
Ademas el funcionamiento no es muy redondo. lo conecte a tres servos pequeños de los microservos y cambio el valor de posicion con el pueeto serie. El programa trabaja pero no muy fino, a veces se van los servos donde quieren
Otra pregunta es.....puedo parar el programa? como?
borrarlo? como.

curro92

Hola,
un método para resolver problemas es ir por partes:
- quítale los servos y todo lo que tengas conectado al arduino: ¿puedes compilar y cargar un programita sencillo sin problemas de puerto?
Si es así los servos serían la causa. Tendrías que decir cómo los conectas, cómo los alimentas, qué servos son...

jray

PC o Mac o Linux?
Qué servos?
Esquema de conexión de los servos y tipo de servos?
Y el código, dónde está el código de gestión de los servos para saber si has escrito algo mal?

Otro post más que requiere de dotes adivinatorias......


He empezado hoy con arduino y ya me surje el primer problema.
El puerto COM me cambia cuando quiere y se me cierra, con lo que no se porque no consigo que tras compilar mandar el programa al arduino, solo a veces, despues de reiniciar. Unas veces me coje el puerto 5 otras el 6 y hasta el Com7.
Ademas el funcionamiento no es muy redondo. lo conecte a tres servos pequeños de los microservos y cambio el valor de posicion con el pueeto serie. El programa trabaja pero no muy fino, a veces se van los servos donde quieren
Otra pregunta es.....puedo parar el programa? como?
borrarlo? como.


algec

Bueno es simple, arduino UNO, tres servos pero lo hace igual con solo uno, Pc ultrabox toshiba, alimentado desde el arduino por el usb sin mas alimentacion. el servo es un micro servo de los mas pequeños. El programa es cualquiera de los de ejemplo que vienen con arduino.
Gracias

Heke

#4
Nov 05, 2012, 12:26 pm Last Edit: Nov 05, 2012, 12:29 pm by Heke Reason: 1


Nada... nada... no preocuparse... el arduino puede con todo...

Para que preocuparse de saber la corriente maxima por pin de salida en el arduino, ¿para que?

Aqui vale todo, se le conecta un servo hoy, una bombilla mañana, un motor de lavadora pasado y asi poco a poco le seguimos conectando cosas...

"...Ancha es Castilla..."  

y "estrecha Leon" (esto ultimo no se porque se dice pero se dice).
CUIDADO !! MIS POST NO SON APTOS PARA MENORES. SI ERES MENOR DE 14 AÑOS DEBES DE LEERLOS ACOMPAÑADO DE UN ADULTO

algec

A ver la alimentacion esta tomada del USB no del pin de salida, el pin de salida solo envia el pulso de control. No soy tan tonto, los tres servos no consumen mas de 100 mAmp juntos funcionando y no creo que tenga nada que ver con el cambio de COM, la tension de 5V no baja .
Llevo trabajando en electronica industrial mas de 30 años y me parece que de eso algo se.
Por cierto no creo que tu respuesta sea muy educada, para responder asi mejor no digas nada.
Muchas gracias y un saludo.

Heke

#6
Nov 05, 2012, 04:24 pm Last Edit: Nov 05, 2012, 04:27 pm by Heke Reason: 1
Una cosa es llevar 30 años trabajando en electronica industrial y otra muy distinta saber electronica.

Si llevas 30 años trabajando en Electronica, empezarias estudiando las valvulas termoionicas y terminarias la carrera con suerte aprendiendote el 6502 o el 8085 ¿verdad?

En todas estas etapas te habran enseñado la importancia de las alimentaciones en los circuitos.

Si es asi deberias saber leer los datasheet de los microprocesadores, deberias saber dimensionar la alimentacion y para mas "INRI" deberias saber que un puerto USB de un PC no da mas de 500mA aparte de la proteccion.

Tambien añadiria que un motor de un servo es una bobina con lo cual te va a producir tensiones inducidas y por si fuera poco, ese motor te va a pedir en el arranque mas corriente que la de mantenimiento en vacio.

Añadiria para rizar el rizo que probablemente no habras puesto un condensador extra, como minimo, para asegurarte la alimentacion de ese consumo extra.

Y por ultimo, "Alma de cantaro" (como diria Jose Mota (( esto es una coña y sin ofender)) ) ¿A quien se le ocurre alimentar motores de continua +  un microprocesador por el puerto USB de un PC?

Me apostaria contigo un cafe a que en el momento que quites los servos y los alimentes con su correspondiente F. de Alimentacion y las salidas del arduino no vayan directamente el estos, sino que los pases por un Buffer de potencia o un simple transistor, el problema desapareceria.

¿Te juegas algo?

Pruebalo y aunque te moleste, reconoceme que te ha funcionado...

Luego con que me invites a un cafe todo zanjado.... XD

Entre los compañeros del metal nunca hay rencores.

Un saludo.
CUIDADO !! MIS POST NO SON APTOS PARA MENORES. SI ERES MENOR DE 14 AÑOS DEBES DE LEERLOS ACOMPAÑADO DE UN ADULTO

algec

A ver llevo como jefe de un turno de mantenimiento electronico mas de 30 años con plcs, microcontroladores, alta, baja, media tension, convertidores de alterna y continua,control de equipos y motores de potencia de miles de watios,sistemas de control de todo tipo , redes modbus etc,  comunicaciones de fibra y....perderia el tiempo enumerando las casas, sistemas etc. Programo en C desde hace años, empece con clipper ....., redes ....y ya no sigo para no aburrir.
No dudo que tengas razon en tu respuesta, solo me quejo de tu forma de expresarte, con gente con tu actitud verbal  mal vamos en los foros, llevo años posteando en foros de Pics y cnc, mantenimiento y aficiones de motos, y nunca conteste como tu ni suelo encontrar gente con esa actitud. Siento decirtelo pero es mi ultimo mensaje en este foro por tu actitud. Sinceramente me molestaste con tu prepotencia en la forma de expresarte. Creo que fui educado y hice una consulta. Puede que de novato, puede que fuese de idiota, no lo se , pero si no quieres responder no lo hagas y te sujiero que apartes esa actitud de prepotencia que tienes.
Aun asi muchas gracias. Ha sido gracias a ti mi primer y ultimo post aqui.
Que te vaya bien y un saludo.
A los responsables del foro......nada que decirles ellos sabran

curro92

Hola,
vuelvo a preguntar: desconectando los servos, ¿puedes cargar programas? ¿tienes problema con el puerto com?

Heke

#9
Nov 05, 2012, 06:26 pm Last Edit: Nov 05, 2012, 06:37 pm by Heke Reason: 1

A ver llevo como jefe de un turno de mantenimiento electronico mas de 30 años con plcs, microcontroladores, alta, baja, media tension, convertidores de alterna y continua,control de equipos y motores de potencia de miles de watios,sistemas de control de todo tipo , redes modbus etc,  comunicaciones de fibra y....perderia el tiempo enumerando las casas, sistemas etc. Programo en C desde hace años, empece con clipper ....., redes ....y ya no sigo para no aburrir.
No dudo que tengas razon en tu respuesta, solo me quejo de tu forma de expresarte, con gente con tu actitud verbal  mal vamos en los foros, llevo años posteando en foros de Pics y cnc, mantenimiento y aficiones de motos, y nunca conteste como tu ni suelo encontrar gente con esa actitud. Siento decirtelo pero es mi ultimo mensaje en este foro por tu actitud. Sinceramente me molestaste con tu prepotencia en la forma de expresarte. Creo que fui educado y hice una consulta. Puede que de novato, puede que fuese de idiota, no lo se , pero si no quieres responder no lo hagas y te sujiero que apartes esa actitud de prepotencia que tienes.
Aun asi muchas gracias. Ha sido gracias a ti mi primer y ultimo post aqui.
Que te vaya bien y un saludo.
A los responsables del foro......nada que decirles ellos sabran


Pero que mal genio compañero !!

Parece mentira que no sepas pillar la coña, ¿Estas seguro que eres del metal? porque normalmente somos mas desinhibidos pero asi pareces un "yayo remugon"

No confundas, no es prepotencia, era simple coña relacionada con lo poco que aportabas para poder solucionar el problema y por lo que te digo de haberle cargado los servos y el arduino al USB.

No te lo tomes a mal que parece llevamos vidas paralelas exceptuando lo de C pues yo en mi epoca di dbase, pascal, cobol, lenguaje maquina por supuesto, y despues el resto de los visuales (visual dbase, foxpro, basic, delphi...) tambien alta y media tension, industria pesada (maquinas ferrocarril) industria mecanica (diesel, gasolina, transmisiones) y por supuesto mantenimiento industrial.

Redes tambien, pues empece desde la epoca de las novell netware hasta la mayoria de las que han salido.

Y de aficiones de motos ya ni te cuento, ya te pondre una foto de mi Bandit.

Mejor dicho te pongo una foto, es esta pero un poco mas sucia la mia y con la lona puesta:


Asi que somo veras, recorremos caminos similares, aunque eso si, reconoceme que yo con mejor humor  XD

Anda, no te lo tomes a mal, enterremos el hacha de guerra (no muy lejos por si acaso) y hagamos las paces.

¿Te parece?

Yo por de pronto y sin que sirva de precedente te pido disculpas por mi "prepotencia" (que repito era coña marinera)

Y si es por el cafe, tranquilo, que te invito yo, palabra.

Un saludo compañero.

PD: Curro92 esta intentando hecharte una mano, mira a ver...
CUIDADO !! MIS POST NO SON APTOS PARA MENORES. SI ERES MENOR DE 14 AÑOS DEBES DE LEERLOS ACOMPAÑADO DE UN ADULTO

[...]
No soy tan tonto, los tres servos no consumen mas de 100 mAmp juntos funcionando y no creo que tenga nada que ver con el cambio de COM, la tension de 5V no baja.
[...]


Creo que esos 100 mA es la intensidad nominal de los servos, pero al arrancar bruscamente y cuando subes el programa el auto-reset provoca que los motores de los servos se muevan de manera errática en esos momentos tendrás una intensidad de pico muy superior a la nominal, jodiéndote la marrana.

Si haces lo que te a puesto curro92 veras al 99% como te funciona bien la placa.


[...]
Si es asi deberias saber leer los datasheet de los microprocesadores, deberias saber dimensionar la alimentacion y para mas "INRI" deberias saber que un puerto USB de un PC no da mas de 500mA aparte de la proteccion.
[...]


@Heke puede ser que tenga USB 3.0 que soportan 900 mA ¡¡tope de power!!  :P

Heke

Quote
@Heke puede ser que tenga USB 3.0 que soportan 900 mA ¡¡tope de power!!  smiley-razz


Ondia!! pues es verdad JRodrigo, se me habia pasado el detalle de los 3.0  tienes razon.

Si es que como yo me muevo con ordenadores antediluvianos con USB del antiguo ni habia reparado en eso...

La lastima que me toca seguir con estas "cascarrias" y lo que le queda porque esta navidad ya me han jodido la paga, se la va a quedar el señor Rajoy para pagar los intereses a la Sra. Merkel

me cachis!!  que pais!!

El  Señor nos pille confesados....

Un saludo
CUIDADO !! MIS POST NO SON APTOS PARA MENORES. SI ERES MENOR DE 14 AÑOS DEBES DE LEERLOS ACOMPAÑADO DE UN ADULTO

algec

Gracias de nuevo por responder.
ME alegro que comprendas que sin conocernos no debias haber usado esos terminos, no creas que soy un imbecil estirado. Pero no soporto la mala educacion, te pido disculpas.
Suzuki tb tengo, una gsx 750, y una guzzi.
Me veras en varios foros de motos,  CNC y pics si andas en ellos, siempre con este nick.
Suelo colaborar en todos,  hago diseños propios y ayudo a los que puedo, solo por aficion.
Trabajo en una fabrica de acero inoxidable en Mantenimiento, sobre todo de laminadoras y seccion de frio.
Pero eso no es para este post, asi que disculpas a los demas.
El USB es 3.0 el pc es un portatil ultrabook toshiba nuevo, deberia dar eso, unos 900 mAmp. No he probado a alimentar el arduino aparte ni los servos, lo hare en cuanto pueda. No veo que ni en el pico de corriente caiga la tension, pero es cosa de ver si la induccion de los motores mete ruido. En ningun momento se resetea el programa del pic, los servos fucionan con normalidad , solo que por lo que sea se cambia solo el COM del 5 al 6 o al 7.
Un saludo

Seguire investigando, no conozco el entorno de arduino aunque parece muy simple en principio, por eso pense que podia ser un tema de configuracion del soft.

Heke

#13
Nov 05, 2012, 07:07 pm Last Edit: Nov 05, 2012, 07:10 pm by Heke Reason: 1
Haber empezado por ahi !!

Desconozco el USB 3.0 si no me equivoco igual hasta llevas windows 7  o el 8   con ese entorno no descarto que puedan haber otras historias.

El arduino como veras es bastante sencillo, viniendo de los PIC lo tienes chupado.

La diferencia es que PIC tiene en varios micros el USB integrado y este lleva un chip FTDI para convertir USB a TTL  (bueno, el tuyo, el UNO, creo que lo han cambiado) por el resto mas o menos igual...

Tu portatil no lleva algun USB 2.0 aparte del 3.0 ? por probar aparte a ver si van por ahi los tiros.

Lo del cambio de USB aparte del tema electrico tambien podia ser tema del SO de microsoft nuevo, sabiendo esto ahora no descartaria ninguna opcion.

V'ss compañero.

Dejemos el cafe de lado y  pasemos a una cerveza bien fria como buen motero.  ;)

PD: Me gusta mucho la 750, similar en motor con la bandit como la mia (el chino fabrico un motor y mil versiones del mismo) pero con mas power. Si no es mucha molestia una fotillo de la guzzi molaria... ¿es clasica, una california, de la nuevas una breva o grisso?
CUIDADO !! MIS POST NO SON APTOS PARA MENORES. SI ERES MENOR DE 14 AÑOS DEBES DE LEERLOS ACOMPAÑADO DE UN ADULTO

algec

A ver, lo hace igual en USB 2 y 3. Tengo que probar lo de la alimentacion , puede ser ruido. Si no es de eso es del software.
Probare con la alimentacion y el pc fijo, ambos van en windows 7, el fijo es un i7 con 12 gigas de ram, el portatil un i5 con 6 gigas.
Si no es de hardware a ver si fuese del windows 7. aunque no se, cuando engancha engancha pero a veces se cambia el puerto solo.
Ya informare de lo de la alimentacion cuando pruebe con tiempo.

La guzzi es mi primera moto que aun conservo, una V50III con 30 años y mas km que rossi, como 150000 o asi.
Pero me gusta y no quiero deshacerme de ella.
La suzi ya tiene como 80000. Y eso que casi no ando ahora a ningun sitio.

Estoy empezando para hacer un hexapodo, al menos esa es la idea, ya sabeis curvas de bezier.....etc. El aburrimiento que es malo,. llueve, y con la edad ya casi no salgo en moto con agua, aunque me gusta casi mas que en seco.
Gracias

Go Up