Go Down

Topic: Problemas com relé (Read 18 times) previous topic - next topic

bubulindo

com groundscomuns o problema não se repetirá?

podes tentar com um relé de estado solido, mas nao garanto que seja melhor. procura por moc31 ou algo assim na fairchildsemi.
Eu não sou o teu criado. Se respondo no fórum é para ajudar todos mediante a minha disponibilidade e disposição. Responder por mensagem pessoal iria contra o propósito do fórum e por isso evito-o.
Se realmente pretendes que eu te ajude por mensagem pessoal, então podemos chegar a um acordo e contrato onde me pagas pela ajuda que eu fornecer e poderás então definir os termos de confidencialidade do meu serviço. De forma contrária toda e qualquer ajuda que eu der tem de ser visível a todos os participantes do fórum (será boa ideia, veres o significado da palavra fórum).
Nota também que eu não me responsabilizo por parvoíces escritas neste espaço pelo que se vais seguir algo dito por mim, entende que o farás por tua conta e risco.

Dito isto, mensagens pessoais só se forem pessoais, ou seja, se já interagimos de alguma forma no passado ou se me pretendes convidar para uma churrascada com cerveja (paga por ti, obviamente).

HugoPT

Quote
com groundscomuns o problema não se repetirá?

Talvez, por isso é que recomendo com o foto-acoplador, assim mata qualquer hipotese pois nao ha necessidade do ground comum, podendo o sistema ser completamente isolado.
Debian,Mint,Ubuntu
Arduino Mega 2560
Arduino Nano
Arduino Duemilanove
MAC OS Montain Lion
Raspberry PI Model B

bubulindo


Quote
com groundscomuns o problema não se repetirá?

Talvez, por isso é que recomendo com o foto-acoplador, assim mata qualquer hipotese pois nao ha necessidade do ground comum, podendo o sistema ser completamente isolado.



Com duas fontes separadas... O shield tem díodos a proteger a bobine?

Aquilo do MOC afinal é MOC3051. LOL
Eu cheguei a usar isto para comutar correntes jeitosas (aquecimento) com um triac e funcionou catita.
http://www.fairchildsemi.com/ds/MO/MOC3052M.pdf
No entanto, o problema seria pior com isto, creio.

Em todo o caso, e olhando bem para o que pretendes no futuro, talvez um filtro seja o que pretendes mesmo que queiras fazer isto com uma fonte e seres tu a comutar as luzes.

Ias precisar duma fonte DC, o tal shield para comutar e podias alimentar o arduino dessa mesma fonte DC... normalmente diria que as fontes DC são já filtradas e talvez eliminasse o problema que vês. Claro que ia dar um pouco mais de trabalho, em termos de ligações e código...

Talvez uma fonte de computador servisse?

Eu não sou o teu criado. Se respondo no fórum é para ajudar todos mediante a minha disponibilidade e disposição. Responder por mensagem pessoal iria contra o propósito do fórum e por isso evito-o.
Se realmente pretendes que eu te ajude por mensagem pessoal, então podemos chegar a um acordo e contrato onde me pagas pela ajuda que eu fornecer e poderás então definir os termos de confidencialidade do meu serviço. De forma contrária toda e qualquer ajuda que eu der tem de ser visível a todos os participantes do fórum (será boa ideia, veres o significado da palavra fórum).
Nota também que eu não me responsabilizo por parvoíces escritas neste espaço pelo que se vais seguir algo dito por mim, entende que o farás por tua conta e risco.

Dito isto, mensagens pessoais só se forem pessoais, ou seja, se já interagimos de alguma forma no passado ou se me pretendes convidar para uma churrascada com cerveja (paga por ti, obviamente).

lmeireles43

pessoal não achei o filtro por aqui, terei que esperar chegar....
testei o pwm dos drivers dos leds que tenho aqui
muito show controlei a intensidade da luz bem como quero....
agora me vem a pergunta, utililei um tip120, existe a possibilidade de isolar os grouns? se conseguir eu alimento o arduino com uma bateria
segui esta ligacao
http://bildr.org/2011/03/high-power-control-with-arduino-and-tip120/

só que ai os grounds se juntam....

bubulindo

#99
Feb 07, 2013, 11:38 pm Last Edit: Feb 07, 2013, 11:40 pm by bubulindo Reason: 1
Controlaste que LEDs?

A luminária? Ou os leds de teste?

Esse esquema tem apenas o problema da ligação da base do transistor directamente no Arduino. O tipo de transistor (um Darlington) apesar de ser bom para correntes altas, certamente que vai dissipar algum calor, não? Tens ideia da corrente que passa por ele?

Outra hipótese seria algo assim...
http://electronics.stackexchange.com/questions/17116/how-to-drive-a-mosfet-with-an-optocoupler

Ou... se já encomendaste um shield com FET (motor shield?) isso provavelmente estará feito lá. :)

Como estás a alimentar tudo?


O shield é algo assim?
http://www.ebay.co.uk/itm/B001-Arduino-high-power-MOSFET-shield-motor-lighting-PWM-DC-control-/221186925850?pt=UK_Computing_Other_Computing_Networking&hash=item337fc4a51a

Este parece muito porreiro. :)
Eu não sou o teu criado. Se respondo no fórum é para ajudar todos mediante a minha disponibilidade e disposição. Responder por mensagem pessoal iria contra o propósito do fórum e por isso evito-o.
Se realmente pretendes que eu te ajude por mensagem pessoal, então podemos chegar a um acordo e contrato onde me pagas pela ajuda que eu fornecer e poderás então definir os termos de confidencialidade do meu serviço. De forma contrária toda e qualquer ajuda que eu der tem de ser visível a todos os participantes do fórum (será boa ideia, veres o significado da palavra fórum).
Nota também que eu não me responsabilizo por parvoíces escritas neste espaço pelo que se vais seguir algo dito por mim, entende que o farás por tua conta e risco.

Dito isto, mensagens pessoais só se forem pessoais, ou seja, se já interagimos de alguma forma no passado ou se me pretendes convidar para uma churrascada com cerveja (paga por ti, obviamente).

Go Up