Go Down

Topic: Arduino uno R3 (Read 979 times) previous topic - next topic

deadreply

Bonjour a tous je suis nouveaux sur le forum.
Depuis maintenant une semaine que jessais duploader un sketch dans mon uno.
Pour debuter jai essayer plein de pc different avec des versions de windows diferent et jai
toujours le meme probleme !
Lordi detect bien je le vois installer sur le com sur laquel il linstall.
la lumiere on verte es bien alumer, la lumiere orange L blink car partout jai lu que cetait le code par defaut dedans.
mais la ou ca se gate cest quand jessais duploader jai toujour un message de com deja utilise... et la lumiere TX reste alumer par la suite.
voila jespere que quelqun va avoir une ide !!

Merci a tous.

skizoh

Une réponse au problème non, mais une idée du problème, ça m'ai arrivé avec plusieurs cartes ( production industrielle sur arduino ) quel ne fonctionne pas, certaine après plusieurs uploads certaine des l'achat.. bien sur c'est triste mais que faire les arduino ne sont pas garanti :s sinon tu peut toujours essayer de basculer sur une machine linux, sa a résolu mon problème une fois mais bon.. à mon avis tu est juste tomber sur une carte défectueuse :s

Sinon vérifie les paramètre d'uploade "board" et "programmer" que tu es bien mis "arduino uno" et programmer "usb asp"..

Test le changement de câble usb aussi..   

Sinon pas d'autre idée.. rachète en une :s

Skizo
Un tien vaux mieux que deux tu l'auras !

LouisR

Bonjour,

Je ne sais pas si c'est la cause de ton pb, mais personnellement, j'ai souvent rencontré des pb avec Arduino R3. je ne sais pas quelle version d'Arduino tu utilise mais pour le R3, il faut impérativement installer les drivers de la version 0.23 ou 1.X. Souvent galéré avec version 0.22 et arduino R.3. Remarque : rien ne t'empêche d'utiliser les drivers de 1.0 et de travailler et d'uploader avec 0.22. ça marche, je bosse comme ça.

deadreply

LouisR Merci du conseil je vais tester ca ce soir en rentrant du boulot !

skizoh Merci de linfo je vais voir avec le conseil de LouisR si ya rien qui se passe je vais contacter voir si ya moyen de faire de quoi
pour ravoir un autre board gratos sinon ben je lacheterais lol.

skizoh jai essayer aussi en linux 64 bit tout est detecter mais je ne peux choisir le com il est en gris !! une idee ?

skywodd

Bonjour,

Windows 32 ou 64 bits ?

Avec mon win7 64 bits j'ai eu quelques problèmes par le passé, résolu assez rapidement avec un simple màj des drivers par ceux fournis dans la dernières version de l'ide.

Un tuto (en anglais) qui détail la procédure à suivre :
http://riverembedded.hackhut.com/2011/12/28/my-arduino-uno-rev-3-and-windows-7-64-bit-installation-unknown-device/
Des news, des tutos et plein de bonnes choses sur http://skyduino.wordpress.com !

68tjs

Quote
j'ai essayé aussi en linux 64 bit tout est detecté mais je ne peux choisir le com il est en gris

C'est que sous Linux, par défaut, le port USB est verrouillé pour des raisons de sécurité.
Attention au langage utilisé les ports COM n'existent que sous Windows !!!!!!!!
Sous linux, dans un terminal, tu fais "lsusb"  et la liste des port s'affichent sous la forme : /dev/tty????.
Avec ma Debian l'arduino est connecté (automatiquement sans que je n'ai rien à faire) au port "/dev/ttyACM0"

Quelle distribution utilise-tu ?
Avec Debian et dérivés (Ubuntu, Mint etc ) dans les dernières versions de l'IDE Arduino le mainteneur du paquet, Scott Howard, a inclu un utilitaire qui te permet automatiquement d'appartenir au groupe "dialout" et donc de déverrouiller l'accès aux ports USB.

Sous d'autres distributions c'est à toi de t'inscrire dans le groupe "dialout".


skywodd


Sous d'autres distributions c'est à toi de t'inscrire dans le groupe "dialout".

Dans le doute un petit coup de :
Code: [Select]
sudo adduser nomdutilisateur dialout
et le problème devrais être réglé.
Des news, des tutos et plein de bonnes choses sur http://skyduino.wordpress.com !

68tjs

Pas si simple : sudo oui mais seulement si sudousers a été configuré !
Il l'est dans Ubuntu par défaut mais ce n'est qu'un choix de canonical.

D'une manière plus générale, et valable quelque soit la distribution, il suffit de faire "su"  et d'entrer le mot de passe root:

$ su
$password :
si le mot de passe est correct on passe en root et $ -> # :
# adduser nomdutilisateur dialout

Go Up