Go Down

Topic: Arduino IDE 1.0.2 (Read 4913 times) previous topic - next topic

flz47655

Quote
Ma questo significa che possiamo usare la 1.5.1 anche con arduino UNO ?


Si

Testato

ottimo, allora inizio ad usare direttamente questa della 2, cosi' mi avvantaggio di due magnitudo su Mike  :smiley-yell:
- [Guida] IDE - http://goo.gl/ln6glr
- [Lib] ST7032i LCD I2C - http://goo.gl/GNojT6
- [Lib] PCF8574+HD44780 LCD I2C - http://goo.gl/r7CstH

erpomata


... ArduinoMicro quando verra' prodotta ? esistono gia' gli schemi o qualche foto ?


http://arduino.cc/forum/index.php/topic,130922.0.html
http://www.paologiammarco.it
http://www.valentinamagni.it

Federico Vanzati



Hanno integrato la 1.0.2 nella 1.5.1.
--> https://github.com/arduino/Arduino/commit/23c7536dc76f34d72e585cc4edda20ccda1681a2

Che potete scaricare da qui:
http://arduino.cc/en/Main/SoftwareDue

Quote

Nel changelog non c'è il fix della seriale del serial monitor.  :smiley-eek:

Molto peggio! Leggi:


ma l'errore sul serial monitor per il quale si deve settare per forza l'inglese non doveva essere risolto su questa release ?


Ti dirò di più, sulle versioni di sviluppo intermedie tra la 1.0.1 e la 1.0.2 il bug non c'era più. Come cavolo hanno fatto a farcelo rientrare nuovamente?  :smiley-sweat:

Il bug è tornato fuori nonostante nelle beta intermedie fosse stato corretto! Incredibile...  :smiley-roll-blue:


Avete provato? A me non sembra che il bug ci sia ancora.
Anche perchè la patch è stata inglobata e magari non è stata segnata nel changelog.

F

leo72


Avete provato? A me non sembra che il bug ci sia ancora.
Anche perchè la patch è stata inglobata e magari non è stata segnata nel changelog.

Ieri sera ho scaricato i sorgenti ed ho compilato l'IDE da quelli, ottenendo una 1.0.2 a 64 bit. Avviato l'ambiente, dopo la domanda di Testato, ho provato a cambiare la risoluzione del monitor seriale ed ho ottenuto lo stesso errore che si aveva sulla 1.0.1 ufficiale. La cosa curiosa è che io è da un paio di mesi che uso solo la versione compilata quindi mi incuriosisce capire questa cosa.
Oggi ho scaricato sul mio desktop la 1.0.2 a 32 bit già compilata e qui il bug non c'è. Curiosa, come cosa.

Testato

#20
Nov 06, 2012, 07:37 pm Last Edit: Nov 06, 2012, 07:48 pm by Testato Reason: 1
confermo, win7-64bit (arduino e' a 32 pero', non c'e' una 64bit per windows)
tutto ok con lingua italiano

Testato anche IDE 1.5.1r2 tutto ok
- [Guida] IDE - http://goo.gl/ln6glr
- [Lib] ST7032i LCD I2C - http://goo.gl/GNojT6
- [Lib] PCF8574+HD44780 LCD I2C - http://goo.gl/r7CstH

leo72

Ho capito l'inghippo. Ho fatto i test ieri sera tardi con la Leonardo, dimenticandomi dei problemi del cambio di porta seriale ogni qual volta la scheda si resetta per cui cambiando velocità viene inviato il segnale di reset e l'errore che mi viene fuori riguarda proprio questo.

Però a questo punto c'è il crash dell'IDE completo! Qualcuno può confermare?
Passi per riprodurre il crash:
1) aprire l'IDE
2) collegare l'Arduino Leonardo
3) caricare un semplice sketch che spedisce qualcosa sulla seriale
4) aprire il monitor seriale
5) cambiare velocità di trasmissione
6) l'IDE risponde che non trova la scheda sulla porta selezionata
7) chiudere il monitor seriale
8) cliccare su Strumenti: l'IDE crasha

niki77

Mi meraviglio di te Leo che ancora vai combattendo con l'ide originale, ma quando ti decidi a passare a qualcosa di più concreto? (E che funziona meglio ovviamente)
Vi è una spiegazione scientifica a tutto.
La fede è solo quell'anello che si porta al dito dopo il matrimonio.


leo72


Mi meraviglio di te Leo che ancora vai combattendo con l'ide originale, ma quando ti decidi a passare a qualcosa di più concreto? (E che funziona meglio ovviamente)

Hai perfettamente ragione ma il problema di fondo è che quando realizzi librerie che poi vuoi distribuire non puoi uscire dal seminato, ossia non puoi metterti ad usare strumenti non supportati dall'Arduino, altrimenti il lavoro che fai poi diventa qualcosa di nicchia, riservato a pochi. Usare l'IDE ufficiale mi permette di realizzare lavori usabili da tutti gli utenti di Arduino.

leo72


Aiutiamo a migliorarlo.

Non mi ricordo dov'è che si fanno le segnalazioni di errori dell'IDE, vorrei segnalare questo problema.

lesto

avranno mergiato qualche file che sistema la seriale e per errore non hanno unito bene le varie modifiche al codice.

@leo per le segnalazioni su github!
sei nuovo? non sai da dove partire? leggi qui: http://playground.arduino.cc/Italiano/Newbie

leo72


leo72

OK, segnalato. Issue #1102
http://code.google.com/p/arduino/issues/detail?id=1102

uwefed


OK, segnalato. Issue #1102
http://code.google.com/p/arduino/issues/detail?id=1102


Non é che a 2000 vinci qualcosa?
Ciao Uwe

Go Up