Go Down

Topic: Arduino bruciato? Prove con 12V (Read 2402 times) previous topic - next topic

uwefed


Visto che hanno 14 pin per lato, gliene avranno spediti una coppia per poter contenere l'Atmega328 visto che è un DIP28.

Questa logica ultra-tecnologica non avovo recepita. ;) ;)
Ciao Uwe

Michele Menniti


Visto che hanno 14 pin per lato, gliene avranno spediti una coppia per poter contenere l'Atmega328 visto che è un DIP28.

:smiley-eek: ma è una battuta senza faccine o cosa?
Guida alla programmazione ISP e seriale dei micro ATMEL (Caricare bootloader e sketch):
http://www.michelemenniti.it/Arduino_burn_bootloader.php
Guida alla Programmazione ATmega328 noP:
http://www.michelemenniti.it/atmega328nop.html
Articoli su Elettronica In:
http://www.michelemenniti.it/elettronica_in.html

shinil35

Niente da fare..
Sono arrivati 10 minuti fa i due atmega, ne ho montato subito uno (come indicato nella figura: http://arduino.cc/en/Main/ArduinoBoardUno) e non cambia assolutamente nulla..
Ora mi trovo quindi con 3 atmega buoni credo, e 0 arduini buoni :(

Dite che c'è qualcos'altro da fare o sicuramente si è bruciata la scheda intera?

Michele Menniti

Sei sicuro che il bootloader dei nuovi sia quello della scheda? Altrimenti devi settare come board quella del bootloader. Cioè se hai una UNO e metti su un micro con bl della 2009, nell'IDE devi settare 2009, altrimenti non ti funziona.
Detto questo a me pare strano che possa essere la scheda, perché il fatto che sia correttamente riconosciuta dal PC significa che funzionano sia l'alimentazione che il micro convertitore USB-Seriale; il resto è componentistica davvero minima, a meno che tu non ci abbia messo mano alla scheda....
L'altra ipotesi potrebbe essere lo zoccolo danneggiato, in questo caso è come se il micro non fosse inserito correttamente, ovvio che non funzioni.
Guida alla programmazione ISP e seriale dei micro ATMEL (Caricare bootloader e sketch):
http://www.michelemenniti.it/Arduino_burn_bootloader.php
Guida alla Programmazione ATmega328 noP:
http://www.michelemenniti.it/atmega328nop.html
Articoli su Elettronica In:
http://www.michelemenniti.it/elettronica_in.html

leo72



Visto che hanno 14 pin per lato, gliene avranno spediti una coppia per poter contenere l'Atmega328 visto che è un DIP28.

:smiley-eek: ma è una battuta senza faccine o cosa?

ROFTL  :smiley-yell:

astrobeed


Detto questo a me pare strano che possa essere la scheda, perché il fatto che sia correttamente riconosciuta dal PC significa che funzionano sia l'alimentazione che il micro convertitore USB-Seriale;


Per essere certi che l'adattatore USB-Seriale è funzionante basta mettere in corto tra loro i pin 0 e 1 (Rx e Tx), senza l'ATmega montato, aprendo la comunicazione con il terminale seriale tutto quello che viene inviato deve tornare indietro sotto forma di eco, se questo non avviene allora c'è un problema sul 8-16u2.

shinil35

L'avevo letto sull'inglese, tipo loopback? Ora provo..
Comunque si i chip che ho preso sono con bootloader dell'uno, ma proverò ugualmente a modificare le impostazioni nell'IDE!

Grazie a tutti, vi faccio sapere al più presto!

shinil35



Detto questo a me pare strano che possa essere la scheda, perché il fatto che sia correttamente riconosciuta dal PC significa che funzionano sia l'alimentazione che il micro convertitore USB-Seriale;


Per essere certi che l'adattatore USB-Seriale è funzionante basta mettere in corto tra loro i pin 0 e 1 (Rx e Tx), senza l'ATmega montato, aprendo la comunicazione con il terminale seriale tutto quello che viene inviato deve tornare indietro sotto forma di eco, se questo non avviene allora c'è un problema sul 8-16u2.



A quanto pare sarà questo il problema!
Perché collegandoli e mandandogli dei dati vedo il led RX che lampeggia ma poi non mi tornano indietro i dati!

Quindi mi tocca a cambiare arduino? :(

uwefed



Detto questo a me pare strano che possa essere la scheda, perché il fatto che sia correttamente riconosciuta dal PC significa che funzionano sia l'alimentazione che il micro convertitore USB-Seriale;


Per essere certi che l'adattatore USB-Seriale è funzionante basta mettere in corto tra loro i pin 0 e 1 (Rx e Tx), senza l'ATmega montato, aprendo la comunicazione con il terminale seriale tutto quello che viene inviato deve tornare indietro sotto forma di eco, se questo non avviene allora c'è un problema sul 8-16u2.


Per l' informazione: Si puó fare questo test anche senza dover togliere il ATMega328
ponticelli il pin reset con il pin GND e i pin TX con il pin RX.
Ciao Uwe

shinil35

Fatto sia con atmega che senza,
Seguendo questa guida:
http://arduino.cc/forum/index.php?topic=73748.0
E purtroppo non mi ritorna indietro nulla, ma quando scrivo lampeggia la luce dell'rx..

Go Up