Go Down

Topic: problème recepteur IR et sortie PWM (Read 2633 times) previous topic - next topic

Artouste


merci ;)
mais ça n'a pas l'air de fonctionner...

bon
principe de base avec un oscillo CRT
a tu déjà une trace plate ? un point ?

bryce_30


bon
principe de base avec un oscillo CRT
a tu déjà une trace plate ? un point ?

oui oui ! mais quand je branche du 5V continu rien ne bouge (je suis bien calibré pour la tension) et quand je me branche sur la pin de test rien ne se passe non plus, alors à part le calibrage de la tension et du temps, je ne sais pas à quoi serve les autres réglages... peut être que c'est du à ça !
par contre autre chose, l'oscillo à quand même l'air fatigué parce que des fois sans rien toucher ma trace bouge et fait des signaux très bizarres pendant quelques dixièmes de secondes !

Artouste



bon
principe de base avec un oscillo CRT
a tu déjà une trace plate ? un point ?

oui oui ! mais quand je branche du 5V continu rien ne bouge (je suis bien calibré pour la tension) et quand je me branche sur la pin de test rien ne se passe non plus, alors à part le calibrage de la tension et du temps, je ne sais pas à quoi serve les autres réglages... peut être que c'est du à ça !
par contre autre chose, l'oscillo à quand même l'air fatigué parce que des fois sans rien toucher ma trace bouge et fait des signaux très bizarres pendant quelques dixièmes de secondes !

bonjour
bon pour resumer :
tu a combien de traces sans rien de connecté ?
fais une photo bien lisible de la face avant de l'oscillo (pour pouvoir annoter des manips)

bryce_30

#18
Nov 10, 2012, 01:40 pm Last Edit: Nov 10, 2012, 01:42 pm by bryce_30 Reason: 1
http://gecko-tec.fr/scan/IMG_0644.jpg

et je n'ai qu'une seule trace

edit : je mets un lien vers la photo pour éviter de prendre trop de place

fdufnews

Sur la photo le sélecteur sur la sonde est en position REF. Donc cela court-circuite la sonde. Tu ne risques pas d'avoir un signal sur ton scope comme ça.
Essaye en position 1:1 pour commencer.

bryce_30

Effectivement c'est beaucoup mieux ! lol ;) j'essai demain sur mon arduino !
merci beaucoup

bryce_30

Donc pour en revenir au sujet principal !
Effectivement il doit y avoir un conflit entre la librairie IRremote et ma pwm. du moment où j'active l'IR, je n'ai plus de signal sur ma sortie.


Mais ce que dit Bryce ce n'est pas que la commande +/6 ne marche pas
C'est que finalement le fade ne marche plus du tout

Donc comme le suggère fdunews, il y a peut être une interaction entre les sorties PWM et la lib IR

D'après la page web de l'auteur, il utilise le TIMER1 pour la réception:
Quote
In more detail, the receiver's interrupt code is called every time the TIMER1 overflows, which is set to happen after 50 microseconds. At each interrupt, the input status is checked and the timer counter is incremented. The interrupt routine times the durations of marks (receiving a modulated signal) and spaces (no signal received), and records the durations in a buffer. The first duration is the length of the gap before the transmission starts. This is followed by alternating mark and space measurements. All measurements are in "ticks" of 50 microseconds.



Mais d'après digital_pin_to_timer_PGM, la pin 11 semble pourtant utiliser le TIMER2



et si j'utilise mon DS1307 comme base de temps pour ma pwm (si c'est possible !) est ce que ça résoudrai mon problème ?

Artouste

bonsoir


Effectivement c'est beaucoup mieux ! lol ;) j'essai demain sur mon arduino !
merci beaucoup


Comme quoi une bonne photo est efficace !
merci qui ? merci Fdfunews  :smiley-mr-green:


...
et si j'utilise mon DS1307 comme base de temps pour ma pwm (si c'est possible !) est ce que ça résoudrai mon problème ?


Un DS1307 n'est pas adapté pour faire une BdT dans cette application de pwm

bryce_30

bonsoir !

oui merci encore ! ;)
bon du coup pour mon projet en cours je vais m'en passer de l'IR

mais juste pour mon info (et surement celle d'autres débutants) est ce que l'IR est incompatible avec une PWM, ou bien c'est juste mon code qui est incompatible ?
n'y a-t-il aucun moyen de contourner ce problème ?

Artouste


...
mais juste pour mon info (et surement celle d'autres débutants) est ce que l'IR est incompatible avec une PWM, ou bien c'est juste mon code qui est incompatible ?
n'y a-t-il aucun moyen de contourner ce problème ?

bonsoir
Si les librairies "standards" IR/PWM impactent/modifient le meme timer, la solution  passera par d'autres voies.

rapide recherche

et çà , cela donne quoi ?
https://gist.github.com/2758364



bryce_30

Bonsoir,
Merci Artouste ! pourtant ce n'st pas faute d'avoir chercher ! mais je n'ai pas du entrer les bonne requêtes sur google !
je vais tester ça !

Go Up