Go Down

Topic: Keine Verbindung zum Board (Read 188 times) previous topic - next topic

Uwe_aus_Bayern

May 17, 2016, 11:02 pm Last Edit: May 18, 2016, 09:42 am by uwefed Reason: add [CODE] TAGs </>
Hallo
Habe mir vor ein paar Tagen ein Startpaket von Sunfounder mit dem Ardunio Board R3 zugelegt. Die Software habe ich runtergeladen von Arduino Download. Den Com Port eingestellt. Das Board gewählt. Danach das Board an den PC angeschlossen. (Windows Version 7). Das Program "Blink" geladen. Bei dem Komilieren erhalte ich die Meldung:
Code: [Select]

C:\Program Files\Arduino\arduino-builder -dump-prefs -logger=machine -hardware "C:\Program Files\Arduino\hardware" -tools "C:\Program Files\Arduino\tools-builder" -tools "C:\Program Files\Arduino\hardware\tools\avr" -built-in-libraries "C:\Program Files\Arduino\libraries" -libraries "C:\Users\Ira\Documents\Arduino\libraries" -fqbn=arduino:avr:uno -vid-pid=0X2341_0X0043 -ide-version=10609 -build-path "C:\Users\Ira\AppData\Local\Temp\buildd5c4b0093dd117dfa33ef4910e564ebc.tmp" -warnings=none -prefs=build.warn_data_percentage=75 -verbose "C:\Users\Ira\Documents\Arduino\Blink\Blink.ino"
C:\Program Files\Arduino\arduino-builder -compile -logger=machine -hardware "C:\Program Files\Arduino\hardware" -tools "C:\Program Files\Arduino\tools-builder" -tools "C:\Program Files\Arduino\hardware\tools\avr" -built-in-libraries "C:\Program Files\Arduino\libraries" -libraries "C:\Users\Ira\Documents\Arduino\libraries" -fqbn=arduino:avr:uno -vid-pid=0X2341_0X0043 -ide-version=10609 -build-path "C:\Users\Ira\AppData\Local\Temp\buildd5c4b0093dd117dfa33ef4910e564ebc.tmp" -warnings=none -prefs=build.warn_data_percentage=75 -verbose "C:\Users\Ira\Documents\Arduino\Blink\Blink.ino"
"C:\Program Files\Arduino\hardware\tools\avr/bin/avr-g++" -c -g -Os -w -std=gnu++11 -fno-exceptions -ffunction-sections -fdata-sections -fno-threadsafe-statics  -w -x c++ -E -CC -mmcu=atmega328p -DF_CPU=16000000L -DARDUINO=10609 -DARDUINO_AVR_UNO -DARDUINO_ARCH_AVR   "-IC:\Program Files\Arduino\hardware\arduino\avr\cores\arduino" "-IC:\Program Files\Arduino\hardware\arduino\avr\variants\standard" "C:\Users\Ira\AppData\Local\Temp\buildd5c4b0093dd117dfa33ef4910e564ebc.tmp\sketch\Blink.ino.cpp" -o "nul"
"C:\Program Files\Arduino\hardware\tools\avr/bin/avr-g++" -c -g -Os -w -std=gnu++11 -fno-exceptions -ffunction-sections -fdata-sections -fno-threadsafe-statics  -w -x c++ -E -CC -mmcu=atmega328p -DF_CPU=16000000L -DARDUINO=10609 -DARDUINO_AVR_UNO -DARDUINO_ARCH_AVR   "-IC:\Program Files\Arduino\hardware\arduino\avr\cores\arduino" "-IC:\Program Files\Arduino\hardware\arduino\avr\variants\standard" "C:\Users\Ira\AppData\Local\Temp\buildd5c4b0093dd117dfa33ef4910e564ebc.tmp\sketch\Blink.ino.cpp" -o "nul"
"C:\Program Files\Arduino\hardware\tools\avr/bin/avr-g++" -c -g -Os -w -std=gnu++11 -fno-exceptions -ffunction-sections -fdata-sections -fno-threadsafe-statics  -w -x c++ -E -CC -mmcu=atmega328p -DF_CPU=16000000L -DARDUINO=10609 -DARDUINO_AVR_UNO -DARDUINO_ARCH_AVR   "-IC:\Program Files\Arduino\hardware\arduino\avr\cores\arduino" "-IC:\Program Files\Arduino\hardware\arduino\avr\variants\standard" "C:\Users\Ira\AppData\Local\Temp\buildd5c4b0093dd117dfa33ef4910e564ebc.tmp\sketch\Blink.ino.cpp" -o "C:\Users\Ira\AppData\Local\Temp\buildd5c4b0093dd117dfa33ef4910e564ebc.tmp\preproc\ctags_target_for_gcc_minus_e.cpp"
open NUL: Das System kann die angegebene Datei nicht finden.
Fehler beim Kompilieren für das Board Arduino/Genuino Uno.


das wars weiter komme ich nicht
was habe ich falsch gemacht?

HotSystems

Was ist das für ein Board?
Hast du außer USB noch etwas anderes angeschlossen?
Welche IDE-Version verwendest du?
I2C = weniger ist mehr: weniger Kabel, mehr Probleme. 8)

michael_x

#2
May 18, 2016, 09:07 am Last Edit: May 18, 2016, 09:20 am by michael_x
Den Fehler kriegst du vermutlich schon beim Verifizieren, egal ob ein Uno oder gar nichts angeschlossen ist?

Windows Version 7 : 64 Bit vermutlich?

Ich hab die IDE (ich verwende noch 1.6.7) bei den 32-Bit Programmen installiert und für jede Version einen Unter-Ordner:

C:\Program Files (x86)\Arduino\1.6.7\

[nachtrag]
Die windows .exe Installation will meine alte version 1.0.6 runterschmeissen, daher will ich sie nicht, sondern verwende die zip - Version.




uwefed

Hast Du versucht dan PC auszuschalten un neu zu starten?
Grüße Uwe

der_chipo

Hallo der Fehler ist doch klar. Du hast die Software unter C:\Program Files (x86)\Arduino\1.6.7\ installiert. Die IDE sucht den Compiler aber unter C:\Program Files\Arduino\. Entweder neu installieren oder den Pfad des AVR dude in C:\Users\Benutzer\AppData\Local\Arduino15\preferences anpassen.

michael_x

So einfach ist es leider nicht:

Ich habe Arduino in  C:\Program Files (x86)\Arduino\1.6.7\

Uwe_ausBayern hat die Version 1.6.9 in  C:\Program Files\Arduino\
Dort wird sein avr-g++ auch gefunden

Uwe_aus_Bayern

Hallo
Erstmal besten Dank für eure Antworten
Ich werde versuchen alle Fragen zu beantworten. Als erstes



Frage: von HotSystems
Was ist das für ein Board?
Hast du außer USB noch etwas anderes angeschlossen?
Welche IDE-Version verwendest du?

Antwort:
Ich habe ein UNO R3 Board
Ich habe nicht anderes angeschlossen nur über USB das Board.
Die Version 1.6.9



Frage: von Michael_X
Den Fehler kriegst du vermutlich schon beim Verifizieren, egal ob ein Uno oder gar nichts angeschlossen ist?

Antwort: Genau, ich erhalte die oben aufgeführte Fehlermeldung auch dann, wenn ich kein UNO Board angeschlossen habe und nur das Program Arduino starte und den Sketch Blink kompiliere



Frage von uwefed
Hast Du versucht dan PC auszuschalten un neu zu starten?

Antwort: Ja mehrfach, leider keinen Erfolg



Um jede Antwort zu meinem Problem bin ich Dankbar



HotSystems

Ich würde in dem Fall die IDE (Programm) deinstallieren und neu installieren. Da ist sicher etwas schief gelaufen.
I2C = weniger ist mehr: weniger Kabel, mehr Probleme. 8)

michael_x

#8
May 18, 2016, 06:26 pm Last Edit: May 18, 2016, 06:30 pm by michael_x
Übrigens, herzlich willkommen im Forum.
Super, dass du ungefragt Fehlermeldungen postest, und sie sogar nachträglich noch durch code-Tags lesbar machst. [Ahem: Das war Uwe !  ;)]

Vermutlich gibt es bei dir das Zwischenergebnis
%TEMP%\buildd5c4b0093dd117dfa33ef4910e564ebc.tmp\preproc\ctags_target_for_gcc_minus_e.cpp
nicht


Zum Vergleich bei mir:

Code: [Select]
C:\Program Files (x86)\Arduino\1.6.7\arduino-builder -dump-prefs -logger=machine -hardware "C:\Program Files (x86)\Arduino\1.6.7\hardware" -hardware "C:\Users\michaelh\Documents\Arduino\hardware" -tools "C:\Program Files (x86)\Arduino\1.6.7\tools-builder" -tools "C:\Program Files (x86)\Arduino\1.6.7\hardware\tools\avr" -built-in-libraries "C:\Program Files (x86)\Arduino\1.6.7\libraries" -libraries "C:\Users\michaelh\Documents\Arduino\libraries" -fqbn=arduino:avr:Standalone328_12 -ide-version=10607 -build-path "C:\Users\michaelh\AppData\Local\Temp\build6c355214f958542a2b57f25ff3f53f7e.tmp" -warnings=all -prefs=build.warn_data_percentage=75 -verbose "C:\Program Files (x86)\Arduino\1.6.7\examples\01.Basics\Blink\Blink.ino"
C:\Program Files (x86)\Arduino\1.6.7\arduino-builder -compile -logger=machine -hardware "C:\Program Files (x86)\Arduino\1.6.7\hardware" -hardware "C:\Users\michaelh\Documents\Arduino\hardware" -tools "C:\Program Files (x86)\Arduino\1.6.7\tools-builder" -tools "C:\Program Files (x86)\Arduino\1.6.7\hardware\tools\avr" -built-in-libraries "C:\Program Files (x86)\Arduino\1.6.7\libraries" -libraries "C:\Users\michaelh\Documents\Arduino\libraries" -fqbn=arduino:avr:Standalone328_12 -ide-version=10607 -build-path "C:\Users\michaelh\AppData\Local\Temp\build6c355214f958542a2b57f25ff3f53f7e.tmp" -warnings=all -prefs=build.warn_data_percentage=75 -verbose "C:\Program Files (x86)\Arduino\1.6.7\examples\01.Basics\Blink\Blink.ino"
"C:\Program Files (x86)\Arduino\1.6.7\hardware\tools\avr/bin/avr-g++" -c -g -Os -w -std=gnu++11 -fno-exceptions -ffunction-sections -fdata-sections -fno-threadsafe-statics  -w -x c++ -E -CC -mmcu=atmega328p -DF_CPU=12000000L -DARDUINO=10607 -DARDUINO_AVR_UNO -DARDUINO_ARCH_AVR   "-IC:\Program Files (x86)\Arduino\1.6.7\hardware\arduino\avr\cores\arduino" "-IC:\Program Files (x86)\Arduino\1.6.7\hardware\arduino\avr\variants\standard" "C:\Users\michaelh\AppData\Local\Temp\build6c355214f958542a2b57f25ff3f53f7e.tmp\sketch\Blink.ino.cpp" -o "nul"
"C:\Program Files (x86)\Arduino\1.6.7\hardware\tools\avr/bin/avr-g++" -c -g -Os -w -std=gnu++11 -fno-exceptions -ffunction-sections -fdata-sections -fno-threadsafe-statics  -w -x c++ -E -CC -mmcu=atmega328p -DF_CPU=12000000L -DARDUINO=10607 -DARDUINO_AVR_UNO -DARDUINO_ARCH_AVR   "-IC:\Program Files (x86)\Arduino\1.6.7\hardware\arduino\avr\cores\arduino" "-IC:\Program Files (x86)\Arduino\1.6.7\hardware\arduino\avr\variants\standard" "C:\Users\michaelh\AppData\Local\Temp\build6c355214f958542a2b57f25ff3f53f7e.tmp\sketch\Blink.ino.cpp" -o "nul"
"C:\Program Files (x86)\Arduino\1.6.7\hardware\tools\avr/bin/avr-g++" -c -g -Os -w -std=gnu++11 -fno-exceptions -ffunction-sections -fdata-sections -fno-threadsafe-statics  -w -x c++ -E -CC -mmcu=atmega328p -DF_CPU=12000000L -DARDUINO=10607 -DARDUINO_AVR_UNO -DARDUINO_ARCH_AVR   "-IC:\Program Files (x86)\Arduino\1.6.7\hardware\arduino\avr\cores\arduino" "-IC:\Program Files (x86)\Arduino\1.6.7\hardware\arduino\avr\variants\standard" "C:\Users\michaelh\AppData\Local\Temp\build6c355214f958542a2b57f25ff3f53f7e.tmp\sketch\Blink.ino.cpp" -o "C:\Users\michaelh\AppData\Local\Temp\build6c355214f958542a2b57f25ff3f53f7e.tmp\preproc\ctags_target_for_gcc_minus_e.cpp"
"C:\Program Files (x86)\Arduino\1.6.7\tools-builder\ctags\5.8-arduino5/ctags" -u --language-force=c++ -f - --c++-kinds=svpf --fields=KSTtzns --line-directives "C:\Users\michaelh\AppData\Local\Temp\build6c355214f958542a2b57f25ff3f53f7e.tmp\preproc\ctags_target_for_gcc_minus_e.cpp"
"C:\Program Files (x86)\Arduino\1.6.7\hardware\tools\avr/bin/avr-g++" -c -g -Os -Wall -Wextra -std=gnu++11 -fno-exceptions -ffunction-sections -fdata-sections -fno-threadsafe-statics -MMD -mmcu=atmega328p -DF_CPU=12000000L -DARDUINO=10607 -DARDUINO_AVR_UNO -DARDUINO_ARCH_AVR   "-IC:\Program Files (x86)\Arduino\1.6.7\hardware\arduino\avr\cores\arduino" "-IC:\Program Files (x86)\Arduino\1.6.7\hardware\arduino\avr\variants\standard" "C:\Users\michaelh\AppData\Local\Temp\build6c355214f958542a2b57f25ff3f53f7e.tmp\sketch\Blink.ino.cpp" -o "C:\Users\michaelh\AppData\Local\Temp\build6c355214f958542a2b57f25ff3f53f7e.tmp\sketch\Blink.ino.cpp.o"
"C:\Program Files (x86)\Arduino\1.6.7\hardware\tools\avr/bin/avr-gcc" -c -g -x assembler-with-cpp -mmcu=atmega328p -DF_CPU=12000000L -DARDUINO=10607 -DARDUINO_AVR_UNO -DARDUINO_ARCH_AVR   "-IC:\Program Files (x86)\Arduino\1.6.7\hardware\arduino\avr\cores\arduino" "-IC:\Program Files (x86)\Arduino\1.6.7\hardware\arduino\avr\variants\standard" "C:\Program Files (x86)\Arduino\1.6.7\hardware\arduino\avr\cores\arduino\wiring_pulse.S" -o "C:\Users\michaelh\AppData\Local\Temp\build6c355214f958542a2b57f25ff3f53f7e.tmp\core\wiring_pulse.S.o"
...


Statt direkt tief einzusteigen ist Neuistallation bestimmt einfacher

Uwe_aus_Bayern

Hallo
Besten Dank für die Tip´s

Wie empfohlen habe ich das Program deinstalliert alle Orner gelöscht und dann aus dem Windows Installer einen download gemacht. Board und com Port eingestellt. Den Sketch "Blink" geladen und kompiliert und erhielt die gleiche Fehlermeldung wie oben dargestellt.

Rechner runter und hochgefahren keine Veränderung

Jetzt habe ich wieder alles gelöscht und noch mals das Program aus dem Windows Zip down geladen. Alles eingestellt und leider wieder die gleiche Fehlermeldung wie oben dargestellt erhalten.

Jetzt stehe ich blöd da und bitte weiter um Hilfestellung


Besten Dank

michael_x

#10
May 18, 2016, 11:42 pm Last Edit: May 18, 2016, 11:42 pm by michael_x
Ich habe einen Laptop mit englischem Windows 8.1 (64 bit)

Ich habe mir von arduino.cc die Windows zip geholt und auf mein zweites Laufwerk nach  D:\Arduino entpackt. (Um mit dem ganzen Administrator-Gedöns nichts zu tun zu haben.)

Dann habe ich im Explorer die Datei D:\Arduino\arduino-1.6.9\arduino.exe doppelgeklickt. Ist gestartet und hat Version 1.6.9 angezeigt.

Habe bei File / Examples - Basic - Blink ausgewählt

Habe  Verifizieren geklickt : OK
Habe bei Preferences - Language auf Deutsch gestellt und arduino.exe beendet

Neu gestartet: Werkzeuge - Board Genuino Uno ausgewählt
Sketch - Überprüfen/Kompilieren Ctrl-R ausgewählt : OK 


Uwe_aus_Bayern

Hallo erstmal besten Dank, speziell an Michel_x für die Antwort.

Hier die Zusammenfassung was ich unternommen habe:

Ich habe mir von arduino.cc die Windows zip geholt und auf mein Wechsellaufwerk nach  F:\Arduino entpackt.

Dann habe ich im Explorer die Datei F:\Arduino\arduino-1.6.9\arduino.exe doppelgeklickt. Ist gestartet und hat Version 1.6.9 angezeigt.

Habe bei File / Examples - Basic - Blink ausgewählt

Habe  Verifizieren geklickt : und leider die Fehlermeldung wie oben beschreiben erhalten

Neu gestartet: Werkzeuge - Board Genuino Uno ausgewählt
Sketch - Überprüfen/Kompilieren Ctrl-R ausgewählt : und leider die Fehlermeldung wie oben beschreiben erhalten

Bei angeschlossenen Board kann ich die Boardkennung einsehen, dass bedeutet doch, dass ich eine Verbindung zum Board zustande bekomme. Nur leider läuft das Arduinoprogram nicht so richtig.

Hier die Angaben zu meinem Rechner:

Laptop von Dell Inspiration N 5030 mit windows 7 home premium service pack 1   32 bit version.

Mit der Bitte um Hilfestellung. Oder sollte ich mir gleich einen Mac zulegen?
 

michael_x

Auf keinen Fall einen Mac!  oder gar Ubuntu!
;)


Mal angenommen, an den Programmdateien liegt es nicht. Dann ist bei einer der früheren Installationen in deinen Benutzerspezifischen Sachen was schief gelaufen.

C:\Users\<deinKonto>\AppData\Roaming\Arduino putzen ...

Go Up
 


Please enter a valid email to subscribe

Confirm your email address

We need to confirm your email address.
To complete the subscription, please click the link in the email we just sent you.

Thank you for subscribing!

Arduino
via Egeo 16
Torino, 10131
Italy