Go Down

Topic: Rotating an iPad long-distance (Read 1 time) previous topic - next topic

Aja B.

I love SparkFun!!  Got this response to my question this morning:

"TX is still D1 and RX is still D0, but they are arranged on the board funny.  Make sure you are using Serial1.read and Serial1.print (Serial.read and Serial.print are for the USB port)."

Changed all the 'Serial's to 'Serial1's, and now it works!  Hallelujah! 

I was so surprised when the Javascript slider actually made the thing turn, I jumped.  :)

PeterH


I was so surprised when the Javascript slider actually made the thing turn, I jumped.  :)


XD
I only provide help via the forum - please do not contact me for private consultancy.

ppolyviou89

How did you change the serial to serial1? i cant do it. It says to me undeclared  =(
HEEEELPPPP

AWOL

Which board have you got selected?
"Pete, it's a fool looks for logic in the chambers of the human heart." Ulysses Everett McGill.
Do not send technical questions via personal messaging - they will be ignored.


AWOL

So, you can't really expect a Serial1, can you?
"Pete, it's a fool looks for logic in the chambers of the human heart." Ulysses Everett McGill.
Do not send technical questions via personal messaging - they will be ignored.

ppolyviou89

#21
Jun 01, 2013, 10:36 pm Last Edit: Jun 01, 2013, 10:40 pm by ppolyviou89 Reason: 1
I thought that it has two rx and tx pins. I just started using the pro mini and generally the arduino.

Do you suspect what I'm doing wrong? because I've used the same code for arduino uno and it worked!

AWOL

#22
Jun 01, 2013, 10:39 pm Last Edit: Jun 01, 2013, 10:41 pm by AWOL Reason: 1
http://arduino.cc/en/Main/ArduinoBoardProMini

Quote
because I've used the same code for arduino uno and it worked!
Conspicuously absent code.
"Pete, it's a fool looks for logic in the chambers of the human heart." Ulysses Everett McGill.
Do not send technical questions via personal messaging - they will be ignored.

ppolyviou89

Ok so the problem is in the code..what has to be added then? I really break my head thats why I'm asking sorry! :smiley-roll-sweat:

AWOL

Quote
so the problem is in the code..what has to be added then?

What has to be added?
The code, of course.
"Pete, it's a fool looks for logic in the chambers of the human heart." Ulysses Everett McGill.
Do not send technical questions via personal messaging - they will be ignored.

ppolyviou89

I posted the code somewhere else shall i post it again? can you have a look please?

AWOL

Or I could go and find this, the only code you've posted, with no mention of Serial1.
"Pete, it's a fool looks for logic in the chambers of the human heart." Ulysses Everett McGill.
Do not send technical questions via personal messaging - they will be ignored.

ppolyviou89

#27
Jun 01, 2013, 11:01 pm Last Edit: Jun 01, 2013, 11:31 pm by ppolyviou89 Reason: 1
Yes thats what I have and as I said it works fine using the Arduino UNO but I want to use it with arduino pro mini. What could the problem be, or what I could be doing wrong?


Any news?? :smiley-roll-blue:

AWOL

"Pete, it's a fool looks for logic in the chambers of the human heart." Ulysses Everett McGill.
Do not send technical questions via personal messaging - they will be ignored.

Go Up