Go Down

Topic: Arduino motori lego (Read 1 time) previous topic - next topic

Buonasera a tutti, sono nuovo nel forum e da poco ho comprato un kit arduino.
Da buon principiante sto cercando di capire il piu possibile.
Allora io ho un motore lego (9v)

come posso farlo per controllarlo da arduino? senza comprare uno shield si rriesce a fare qulcosa?
Io non riesco nemmeno a farlo funzionare... ha i soliti 2 cavi positivo e negativo.
GRaize e scusate per quanto sia noob.. XD

Brunello

tutto si fa'... comunque per farlo funzionare basta attaccarci un alimentatore da 9V ( che abbia una corrente adeguata ), al limite per provare ( sempre che non assorba troppo ) una pila da 9V
Il rosso sul positivo, il nero sul negativo

e percollegarlo ad arduino, dipende da:

Quanto assorbe ( andrebbe misura la corrente )
Se lo vuoi far ruotare solo in un senso o anche invertire il senso di marcia
Se vuoi controllare la velocita' di rotazione ( farlo andare piu' o meno veloce )

LucaGilardi

Ciao, ti dico che puoi utilizzarlo senza grossi problemi per esperienza. Se vuoi farlo andare in una sola direzione puoi usare un transistor, se invece hai necessità di invertirla puoi usare un ponte H. Per controllare la velocità puoi usare un pin PWM. Ti consiglio di dimensionare il circuito per reggere 2A, perchè a carico ho fatto delle prove pratiche ed assorbono tantissimo quei motori...non collegarli direttamente ad arduino altrimenti friggi qualcosa :)

per farlo funzionare e basta, collegalo ad un alimentatore, più ad uno dei due cavetti, meno all'altro. Alimentalo da 7.2 a 9V.

Se hai altri problemi o domande chiedi pure :)

Luca

Ho provato a collegarlo diretto a una batteria a 9v e non fa niente, qualcosa si setne girare ma non dà nessun cenno di vita! NOn vorrei fosse bruciato.
ora qua non ho un transistor, se devo ordianrlo a sto punto ordino la shield.
MA prima devo vedere se funziona
Luca tu come l hai collegato?

mi sa che senza un L293D questo motore non si muove.
Piu che altro voglio sapere se è bruciato o no...

Brunello


mi sa che senza un L293D questo motore non si muove.
Piu che altro voglio sapere se è bruciato o no...


Mi sa' che senza un alimentatore da 9V e almeno 2A non si muovera' mai.
Prima procurati questo, ci attacchi il motore e guardi se gira ( pare di si, visto che con la piletta accennava a farlo ) e poi pensi al transistor, al ponte H etc etc


Ho un alimentatore da 9v500mA potrebbe farlo girare?

Brunello

prova, ma credo proprio di no.
500 mA di spunto lo da' anche la batteria a 9 V

Ho provato e infatti non va.
Beh dovrò procurarmi un alimentatore da 2A allora, appena provo ti faccio sapere!!
Grazie per ora  ;)

Brunello

comunque mi sembra strano che un motorino della lego non parta con 500mA.
E comunque, alimentandolo e aiutandolo a partire girando a mano l'albero motore, qualcosa si dovrebbe muovere


LucaGilardi

Purtroppo non riesci a farlo muovere con così poca corrente...assorbe circa 1,5A di spunto...

SI ma a me sembra strano, comunque ho trovato questo con scritto gli amperaggi ecc...
http://www.philohome.com/motors/motorcomp.htm

astrobeed


Purtroppo non riesci a farlo muovere con così poca corrente...assorbe circa 1,5A di spunto...


Il motore in oggetto è abbastanza fiacco come potenza, infatti assorbe solo 9mA a vuoto e 340 mA in stallo come riportato in questa pagina con tutte le caratteristiche tecniche dei vari motori Lego a 9V.
In pratica si riesce a farlo girare senza problemi con una normale batteria da 9V, se non gira è perché ha problemi elettrici o meccanici.

LucaGilardi



Purtroppo non riesci a farlo muovere con così poca corrente...assorbe circa 1,5A di spunto...


Il motore in oggetto è abbastanza fiacco come potenza, infatti assorbe solo 9mA a vuoto e 340 mA in stallo come riportato in questa pagina con tutte le caratteristiche tecniche dei vari motori Lego a 9V.
In pratica si riesce a farlo girare senza problemi con una normale batteria da 9V, se non gira è perché ha problemi elettrici o meccanici.


Allora o io ho usato dei motori lego provenienti da Marte o non ne ho idea...Quelli che ho usato io assorbono circa 400mA a vuoto, quasi 1,5A di spunto o con molto carico e hanno una potenza non esagerata ma di tutto rispetto...

astrobeed


.Quelli che ho usato io assorbono circa 400mA a vuoto, quasi 1,5A di spunto o con molto carico e hanno una potenza non esagerata ma di tutto rispetto...


La Lego di motori ne ha rilasciati molti nell'arco del tempo, quello in oggetto di sicuro è poco potente e assorbe poca corrente, poi se tu hai un motore diverso che richiede più corrente non lo metto in dubbio, però qui tocca fare riferimento a quel modello specifico.

Go Up