Go Down

Topic: come digitalizzare con questi livelli di tensione (Read 2008 times) previous topic - next topic

stefa24

#30
Nov 11, 2012, 04:42 pm Last Edit: Nov 11, 2012, 04:44 pm by stefa24 Reason: 1
grazie per il supporto
@Astrobeed posto lo schema come indicato,
@ flz47655 non mi riconosce il componente, sicuramente sbaglio qualcosa

https://sites.google.com/site/agritronica/
https://sites.google.com/site/t3chconcrete/
arduino UNO rev 3
ide 105

stefa24

#31
Nov 11, 2012, 05:12 pm Last Edit: Nov 11, 2012, 05:18 pm by stefa24 Reason: 1

Questo è un esempio di come utilizzare un LM358 in LtSpice:
- Copia i file allegati in C:\Program Files\LTC\LTspiceIV\lib\sub servono per dire a LTSpice come funziona il LM358
- Nel circuito aggiungi la direttiva:   ".lib LM358.MOD.txt"
- Imposta il nome dell'opamp2 come "LM358/NS"

dovresti ottenere qualcosa di simile a:


Ciao


ciao
non vedo l'immagine, ho seguito le istruzioni ma ottengo un messaggio d'errore
"xu2 n006 n003 n005 n004 .lib lm358.mod.txt lm358ns"
ho anche rinominato i pin di opamp2 in accordo a quello scritto nel file .mod.txt, ma niente
non ho capito il perchè di due file per lo stesso componente

grazie
stefano
https://sites.google.com/site/agritronica/
https://sites.google.com/site/t3chconcrete/
arduino UNO rev 3
ide 105

flz47655

http://imageshack.us/photo/my-images/838/circuitok.png/

In alternativa se trovi difficoltà il programma TINA-TI è gratuito http://www.ti.com/tool/tina-ti ed ha il componente di default

stefa24



@uwe
ho trovato il modello LMV358 stasera provo a inserirlo e vedo che risultati ottengo dalla simulazione,


Prima cosa, gli SPICE mentono, devi conoscere l'elettronica molto meglio di loro per poterli usare in modo corretto e capire se i risultati ottenuti sono attendibili oppure no.
Secondo, devi alimentare il LM358 a 5V, e pure questo te lo avevo già detto, se lo alimenti a 3.3V non ottieni il range necessario di tensione.


ciao
ho corretto con i 5v
per il resto concordo che devi conoscere la materia meglio di loro stessi, ma per hobby se non ci si può fidare un minimo non si può sempre chiedere al forum

grazie
stefano
https://sites.google.com/site/agritronica/
https://sites.google.com/site/t3chconcrete/
arduino UNO rev 3
ide 105

stefa24


http://imageshack.us/photo/my-images/838/circuitok.png/

In alternativa se trovi difficoltà il programma TINA-TI è gratuito http://www.ti.com/tool/tina-ti ed ha il componente di default


allego il .asc

grazie
https://sites.google.com/site/agritronica/
https://sites.google.com/site/t3chconcrete/
arduino UNO rev 3
ide 105

flz47655

Devi impostare come "value" dell'op-amp2 "LM358/NS"
Ti allego un esempio di LM358 in configurazione non invertente

Ciao

flz47655

Ecco il tuo file corretto

stefa24

ciao
grazie per il supporto, adesso vedo di passare al modello reale per vedere che succede

stefano
https://sites.google.com/site/agritronica/
https://sites.google.com/site/t3chconcrete/
arduino UNO rev 3
ide 105

flz47655

Ecco dalla simulazione quello che si ottiene in uscita all'op-amp (verde) dato il segnale dell'ingresso non invertente (blu)

stefa24

ciao
si esatto è quello che ottengo domani vedo di fare la prove hardware

stefano
https://sites.google.com/site/agritronica/
https://sites.google.com/site/t3chconcrete/
arduino UNO rev 3
ide 105

Go Up