Pages: 1 [2]   Go Down
Author Topic: Upload error: avrdude: ser_open(): can't set com-state for "\\.\COM17"  (Read 7822 times)
0 Members and 1 Guest are viewing this topic.
Espoo, Finland
Offline Offline
God Member
*****
Karma: 7
Posts: 586
"Oops, try again..."
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

yes of course...


Yes of course... "Yes, you have tried" or "Yes of course, I should have tried that and it works"?

Cheers,
Kari
Logged


The only law for me; Ohms Law: U=R*I       P=U*I
Note to self: "Damn! Why don't you just fix it!!!"

Offline Offline
Newbie
*
Karma: 0
Posts: 36
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

I tried and it didn't work...smiley
Logged

Espoo, Finland
Offline Offline
God Member
*****
Karma: 7
Posts: 586
"Oops, try again..."
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Ok. Then I must apologise, I cannot help more.

Does it work with another computer? If the same problem exists, then your Arduino is probably broken. Oh, I read the first post again, problem lies in your Windows. Drivers are ok?

Kari
Logged


The only law for me; Ohms Law: U=R*I       P=U*I
Note to self: "Damn! Why don't you just fix it!!!"

Offline Offline
Newbie
*
Karma: 0
Posts: 36
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

yes it works an my asus netbook as i said before
yes, the seems to be ok
Logged

Scotland
Online Online
Edison Member
*
Karma: 24
Posts: 1241
Have you had your Arduino fix today?
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

try this :

unplug arduino
in device manager remove all com ports
reboot pc

it should pnp com ports again
take a note of ports
plug in arduino
test again


Drew.
Logged

Drew.
http://www.uk-pcb.co.uk - My UK Based PCB Fab & Assembly Company
Design work undertaken
SMD & Thru-Hole assembly

Espoo, Finland
Offline Offline
God Member
*****
Karma: 7
Posts: 586
"Oops, try again..."
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Without knowing what sofware and virtual com-port drivers are installed in your Windows, it's hard to guess, what is going on. Bluetooth drivers can be one, but it doesn't explain, why COM10 don't work when connected.

Kari
Logged


The only law for me; Ohms Law: U=R*I       P=U*I
Note to self: "Damn! Why don't you just fix it!!!"

Offline Offline
Newbie
*
Karma: 0
Posts: 4
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Hi,

I faced exactly the same troubles on my Arduino UNO, and went through
- reboot (multiple times...)
- driver re-installation
- Arduino application re-installation....
- change the micro-controller

And finally bought a new Arduino UNO and it worked again immediately.

I don't know if we'll find how to solve the problem, I think something failed on the board while connecting a number of steppers directly, but I did not manage to find out the root cause. At least, a workaround with a new board immediately works fine !!!

Logged

Pages: 1 [2]   Go Up
Jump to: