Go Down

Topic: [RISOLTO]LM35DZ e pir sensore di movimento come farli funzionare? (Read 11277 times) previous topic - next topic

alberto39


devi aggiungere una resistenza da 10 kohm sul circuito, tra i fili rosso e nero del sensore

michele cosi e giusto??

cioè ci devono essere tre R
e sono due R 10k

Michele Menniti

Alberto, però così usciamo pazzi, inoltre rischi di "sbampare" Arduino. Siamo rimasti che Arduino lo togli di mezzo, stiamo lavorando a 12V, NON puoi applicarli ad Arduino. Quindi dimentica sto cavolo di Fritzing e cerchiamo di comicniare daccapo, ok?
Guida alla programmazione ISP e seriale dei micro ATMEL (Caricare bootloader e sketch):
http://www.michelemenniti.it/Arduino_burn_bootloader.php
Guida alla Programmazione ATmega328 noP:
http://www.michelemenniti.it/atmega328nop.html
Articoli su Elettronica In:
http://www.michelemenniti.it/elettronica_in.html

alberto39


Alberto, però così usciamo pazzi, inoltre rischi di "sbampare" Arduino. Siamo rimasti che Arduino lo togli di mezzo, stiamo lavorando a 12V, NON puoi applicarli ad Arduino. Quindi dimentica sto cavolo di Fritzing e cerchiamo di comicniare daccapo, ok?

ok ok tutto da capo e con la 12v.


Michele Menniti

Bene, allora devi realizzare questo collegamento:
filo rosso del sensore direttamente al positivo dei 12V
filo marrone del sensore direttamente al negativo dei 12V
una resistenza da 10kohm tra i fili rosso e nero del sensore
poi colleghi il multimetro (portata 20V):
puntale positivo sul filo nero
puntale negativo sul filo marrone

Quando accendi l'alimentatore, con il PIR che non rileva nulla, sul multimetro devi leggere 12V circa
Appena fai rilevare una presenza al PIR sul multimetro devi leggere 0V circa

Arduino e le altre resistenze per ora lasciale fuori dalle prove

Dimmi come va così

EDIT: non farti prendere dalla fretta, il tempo per scrivere mi serve...
Guida alla programmazione ISP e seriale dei micro ATMEL (Caricare bootloader e sketch):
http://www.michelemenniti.it/Arduino_burn_bootloader.php
Guida alla Programmazione ATmega328 noP:
http://www.michelemenniti.it/atmega328nop.html
Articoli su Elettronica In:
http://www.michelemenniti.it/elettronica_in.html

alberto39


Bene, allora devi realizzare questo collegamento:
filo rosso del sensore direttamente al positivo dei 12V
filo marrone del sensore direttamente al negativo dei 12V
una resistenza da 10kohm tra i fili rosso e nero del sensore
poi colleghi il multimetro (portata 20V):
puntale positivo sul filo nero
puntale negativo sul filo marrone

Quando accendi l'alimentatore, con il PIR che non rileva nulla, sul multimetro devi leggere 12V circa
Appena fai rilevare una presenza al PIR sul multimetro devi leggere 0V circa

Arduino e le altre resistenze per ora lasciale fuori dalle prove

Dimmi come va così

EDIT: non farti prendere dalla fretta, il tempo per scrivere mi serve...


michele io messo il positivo del alimentatore nella basetta del filo + quindi il filo positivo e diretto dalla alimentatore al pir poi ho collegato a mo di ponte tra la fila + della basetta e altra parte della R collegata al filo nero
giusto??

Michele Menniti

Come descrittore sei micidiale, non ho capito una mazza :smiley-eek-blue:
Purtroppo tra fili volanti e breadboard hai un bel casino lì.
Comunque leggi con attenzione cosa ti ho scritto e non puoi sbagliare, io a spiegare sono bravo XD; se fai bene i collegamenti alla fine devi trovarti:
SENSORE PIR INATTIVO:
col tester tra rosso e marrone devi avere 12V
col tester tra nero e marrone devi avere 12V

SENSORE PIR ATTIVO:
col tester tra rosso e marrone devi avere 12V
col tester tra nero e marrone devi avere 0V

Sono cotto, leggerò l'esito delle tue prove domattina
Guida alla programmazione ISP e seriale dei micro ATMEL (Caricare bootloader e sketch):
http://www.michelemenniti.it/Arduino_burn_bootloader.php
Guida alla Programmazione ATmega328 noP:
http://www.michelemenniti.it/atmega328nop.html
Articoli su Elettronica In:
http://www.michelemenniti.it/elettronica_in.html

alberto39

#67
Nov 17, 2012, 12:42 am Last Edit: Nov 17, 2012, 01:04 am by alberto39 Reason: 1

Come descrittore sei micidiale, non ho capito una mazza :smiley-eek-blue:
Purtroppo tra fili volanti e breadboard hai un bel casino lì.
Comunque leggi con attenzione cosa ti ho scritto e non puoi sbagliare, io a spiegare sono bravo XD; se fai bene i collegamenti alla fine devi trovarti:
SENSORE PIR INATTIVO:
col tester tra rosso e marrone devi avere 12V
col tester tra nero e marrone devi avere 12V

SENSORE PIR ATTIVO:
col tester tra rosso e marrone devi avere 12V
col tester tra nero e marrone devi avere 0V

Sono cotto, leggerò l'esito delle tue prove domattina

michele lo so che non sono bravo a scrivere le cose, e mi dispiace tanto tanto.
tra rosso e marrone ho 12V
tra nero e marrone ho 3.20v
ciao e buonanotte

Michele Menniti

Ma no, figurati, è per dirti che a questo punto meglio che ti spieghi con un altro schema Fritzing, togliendo di mezzo Arduino. ;)
3.2V è un valore strano, ma c'è differenza tra sensore attivo e sensore inattivo? il problema è tutto lì, per questo ti ho scritto cosa devi trovare con sensore attivo e con sensore inattivo. Se non noti alcuna differenza allora posta lo schema fritzing dei nuovi collegamenti e stabiliamo con certezza se è difettoso, come sembra.
Guida alla programmazione ISP e seriale dei micro ATMEL (Caricare bootloader e sketch):
http://www.michelemenniti.it/Arduino_burn_bootloader.php
Guida alla Programmazione ATmega328 noP:
http://www.michelemenniti.it/atmega328nop.html
Articoli su Elettronica In:
http://www.michelemenniti.it/elettronica_in.html

alberto39

i fili all'inizio sono quelli che vengono dal alimentatore. No c'è cambiamento.

Michele Menniti

Lo schema è corretto. Il valore misurato è strano. Se mi confermi che la misura l'hai effettuata tra nero e marrone e che non cambia a prescindere dal fatto che il PIR sia attivo o inattivo, allora puoi stare certo che è difettoso.
Ti spiego: in condizioni di PIR inattivo sul filo nero si deve venire a trovare una tensione da 12V proveniente dalla resistenza di pull-up da 10k; quando il sensore si attiva, il transistor interno conduce e sul filo nero si deve venire a trovare una tensione prossima a 0V. Quindi non esiste una possibilità che tu possa avere 3,2V fissi, né in un caso né nell'altro, ecco perché credo proprio sia difettoso.
fattelo sostituire e quando ti arriva l'altro rifai direttamente questa stessa prova. Se va tutto bene comunicamelo in questo stesso Topoic che poi riprendiamo il discorso con i 5V e con Arduino.
Guida alla programmazione ISP e seriale dei micro ATMEL (Caricare bootloader e sketch):
http://www.michelemenniti.it/Arduino_burn_bootloader.php
Guida alla Programmazione ATmega328 noP:
http://www.michelemenniti.it/atmega328nop.html
Articoli su Elettronica In:
http://www.michelemenniti.it/elettronica_in.html

alberto39

Ciao a tutti, allora il pir aveva i collegamenti fatti male cioè il fili sono saldati male, quindi lo schema è
ROSSO--------> ALLARME
MARRONE------->GND
NERO------->5 VOLT
michele ho fatto la prova con il multimetro con i colori cambiati e tutto funziona ora che devo fare per collegarlo con arduino?

Michele Menniti

Ma sei proprio sicuro che devi applicare l'alimentazione tra nero (+) e marrone (-) e sul rosso hai l'uscita? Che prove hai fatto? Con che alimentazione? Che risultati hai avuto?
Guida alla programmazione ISP e seriale dei micro ATMEL (Caricare bootloader e sketch):
http://www.michelemenniti.it/Arduino_burn_bootloader.php
Guida alla Programmazione ATmega328 noP:
http://www.michelemenniti.it/atmega328nop.html
Articoli su Elettronica In:
http://www.michelemenniti.it/elettronica_in.html

alberto39

#73
Nov 29, 2012, 11:30 pm Last Edit: Nov 29, 2012, 11:44 pm by alberto39 Reason: 1
si si michele il pir è tornato oggi dal sito dove lo preso, e me lo ha detto lui di questo fatto poi oggi quando, è arrivato il pir ho fatto il collegamento che mi avevi detto tu,adesso sul filo rosso(allarme) marrone(gnd) ho 12volt e poi se passo la mano ho zero.Infatti quando avevo fatto la misurazione con il vecchio collegamento avevo 3.20 volt e tu mi avevi detto che era strano ecco il perchè.
Ora che devo fare per fallo funzionare con arduino, per prima cosa dobbiamo vedere se il pir funziona a 5 volt come si fa per vedere se funziona a 5 volt??

Michele Menniti

ok, ora è tutto chiaro; devi semplicemente alimentarlo a 5V invece che a 12V. Se funziona troverai normalmente 5V e quando passi la mano 0V.
Guida alla programmazione ISP e seriale dei micro ATMEL (Caricare bootloader e sketch):
http://www.michelemenniti.it/Arduino_burn_bootloader.php
Guida alla Programmazione ATmega328 noP:
http://www.michelemenniti.it/atmega328nop.html
Articoli su Elettronica In:
http://www.michelemenniti.it/elettronica_in.html

Go Up