Pages: 1 ... 4 5 [6] 7   Go Down
Author Topic: [RISOLTO]LM35DZ e pir sensore di movimento come farli funzionare?  (Read 9550 times)
0 Members and 1 Guest are viewing this topic.
Tuscany
Offline Offline
Edison Member
*
Karma: 80
Posts: 2176
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Quote
Ciao a tutti, allora il pir aveva i collegamenti fatti male cioè il fili sono saldati male, quindi lo schema è
ROSSO--------> ALLARME
MARRONE------->GND
NERO------->5 VOLT


ma che sono tutti rinc.....iti i fabbricanti.

ma si puo' usare uno schema colori del genere
Logged

Lamezia Terme
Offline Offline
Shannon Member
****
Karma: 574
Posts: 12678
Le domande di chi vuol imparare rappresentano la sua sete di sapere
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

Se ho ben capito questo è il frutto di una riparazione, i fili non erano saldati bene e qualcuno ha pensato di saldarli come gli venivano e poi fornire le necessarie indicazioni; comunque, l'importante ora è che lo tenga sempre presente Alberto anche se io, fossi al suo posto, li "standardizzerei", ma per il momento è meglio evitare nuovi elementi di disturbo in queste prove, prima arriviamo alla fine, che è vicina, sembra smiley-cool
Logged


Torino (ITA)
Offline Offline
Full Member
***
Karma: 1
Posts: 161
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

allora michele scusami se ti rispondo solo ora ma volevo essere sicuro di quello che ti dirò.
alimentando il pir con 5 volt tra il filo di allarme e GND c'è una tensione che varia da 0 a 5 volt, alcune volte si stabilizza ai 5 volt e se poi passo la mano diventa zero e poi mi da tutti i numeri tra 0 a 5.
Invece quando lo facevo con la 12volt, avevo 12volt quando non passavo la mano, poi se la passavo diventava subito zero, poi tornava a 12volt.
Che mi cosigli di fare prima di dire che a 5 volt non funziona?
Logged

Lamezia Terme
Offline Offline
Shannon Member
****
Karma: 574
Posts: 12678
Le domande di chi vuol imparare rappresentano la sua sete di sapere
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

Sembrerebbe funzionare male a 5V, però se il comportamento è fisso si rimedia lato Arduino. Scusami però ora dovresti mostrarmi (magari linka il post preciso) nuovamente che collegamenti stai usando, più che altro mi interessa sapere se ci sono resistenze esterne, come avevamo detto. Poi però dovresti spiegarmi meglio questo comportamento. Proviamo con domande secche:
Alimenta il sensore in modo che punti verso il vuoto:
- dagli 5 secondi di stabilizzazione e dimmi se il tester segna 5V stabili
- ora passa la mano lentamente davanti al sensore, il tester segnala subito 0V o comunque ci arriva dopo poco tempo?
- dopo aver tolto la mano il tester segnala nuovamente 5V?
- se lo lasci 5 minuti (REALI) puntato sul vuoto, il tester segna 5V fissi o ogni tanto fluttuano?
- se gli passi la mano (tipo pendolo d'orologio) per un minuto cosa fa il tester?
Se è SEMPRE lento il passaggio da 0 a 5V potrebbe non essere un vero problema per noi, l'importante è che il sensore si comporti sempre allo stesso modo e non abbia invece risposte random.
Gentilmente quota le mie domane e metti la relativa risposta sotto ogni domanda, non fare riassunti per favore.
Logged


Torino (ITA)
Offline Offline
Full Member
***
Karma: 1
Posts: 161
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Sembrerebbe funzionare male a 5V, però se il comportamento è fisso si rimedia lato Arduino. Scusami però ora dovresti mostrarmi (magari linka il post preciso) nuovamente che collegamenti stai usando, più che altro mi interessa sapere se ci sono resistenze esterne, come avevamo detto.
ecco il post che mi indica lo schema http://arduino.cc/forum/index.php/topic,131578.msg999614.html#msg999614
Logged

Lamezia Terme
Offline Offline
Shannon Member
****
Karma: 574
Posts: 12678
Le domande di chi vuol imparare rappresentano la sua sete di sapere
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

bene, lo schema è giusto, hai fatto tutte le misure che ti ho chiesto, che mi dici?
Logged


Torino (ITA)
Offline Offline
Full Member
***
Karma: 1
Posts: 161
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

bene, lo schema è giusto, hai fatto tutte le misure che ti ho chiesto, che mi dici?
si sto cercando di dare una risposta alle tue domande, ma mi sono fermato alla prima domanda
- dagli 5 secondi di stabilizzazione e dimmi se il tester segna 5V stabili
perchè il tester mi rivela 5v non stabili, sto verificando se colpa mia cioè che non ho la mano ferma o è il pir
Logged

Lamezia Terme
Offline Offline
Shannon Member
****
Karma: 574
Posts: 12678
Le domande di chi vuol imparare rappresentano la sua sete di sapere
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

temo sia il pir, non è che a 12v hai la mano ferma e a 5V no! smiley-grin
se ricordi ti avevo detto che dalle specifiche risultava funzionante a 12V ma poi era venuto il dubbio e per questo proviamo. Se appuri che non sono stabili inutile fare tutte le altre prove, lo dobbiamo usare a 12V e buonanotte.
Logged


Torino (ITA)
Offline Offline
Full Member
***
Karma: 1
Posts: 161
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

temo sia il pir, non è che a 12v hai la mano ferma e a 5V no! smiley-grin
se ricordi ti avevo detto che dalle specifiche risultava funzionante a 12V ma poi era venuto il dubbio e per questo proviamo. Se appuri che non sono stabili inutile fare tutte le altre prove, lo dobbiamo usare a 12V e buonanotte.
e si non è stabile. ok usiamo la 12volt perchè non vedo l'ora di usarlo per un pò. smiley-money smiley-money
dimmi che devo fare cosi concludiamo
Logged

Lamezia Terme
Offline Offline
Shannon Member
****
Karma: 574
Posts: 12678
Le domande di chi vuol imparare rappresentano la sua sete di sapere
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

che valori di resistenza hai da 1k a 22k?
Logged


Torino (ITA)
Offline Offline
Full Member
***
Karma: 1
Posts: 161
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

che valori di resistenza hai da 1k a 22k?
ho le resistenze che ci sono nel kit workshop livello base http://store.arduino.cc/it/index.php?main_page=product_info&cPath=2&products_id=131
e ha quando ho capito ho 5 R da 10k e 5 da 2.2k sono utili ??
Logged

Lamezia Terme
Offline Offline
Shannon Member
****
Karma: 574
Posts: 12678
Le domande di chi vuol imparare rappresentano la sua sete di sapere
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

azzz, vediamo... ho un dubbio e me lo devi togliere tu con una prima prova, sempre ALLA LARGA da Arduino.
Allo schema così com'è aggiungi per ora una 2,2k tra l'allarme e GND, poi applica di nuovo i 12V e misura cosa succede in presenza o assenza di attività del PIR.
Logged


Torino (ITA)
Offline Offline
Full Member
***
Karma: 1
Posts: 161
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

azzz, vediamo... ho un dubbio e me lo devi togliere tu con una prima prova, sempre ALLA LARGA da Arduino.
Allo schema così com'è aggiungi per ora una 2,2k tra l'allarme e GND, poi applica di nuovo i 12V e misura cosa succede in presenza o assenza di attività del PIR.
quindi alla fine nel mio piccolo circuito ci sono due R una da 2.2k e solita quella che c'è nello schema che ti ho indicato prima giusto?
Logged

Lamezia Terme
Offline Offline
Shannon Member
****
Karma: 574
Posts: 12678
Le domande di chi vuol imparare rappresentano la sua sete di sapere
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

sì, quella da 2,2k per va collegata tra allarme e GND, NON come l'altra.
Logged


Tuscany
Offline Offline
Edison Member
*
Karma: 80
Posts: 2176
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Michele, hai cenato ?

la vedo lunga.....
Logged

Pages: 1 ... 4 5 [6] 7   Go Up
Jump to: