Go Down

Topic: [RISOLTO]LM35DZ e pir sensore di movimento come farli funzionare? (Read 10876 times) previous topic - next topic

alberto39

Nov 09, 2012, 03:52 pm Last Edit: Dec 01, 2012, 11:48 pm by alberto39 Reason: 1
Ciao a tutti oggi mi sono arrivati tre prodotti che avevo comprato un dispay lcd 16x4 e LM35DZ e un pir sensore di movimento, ma lasciando stare il pir, volevo fare un piccolo progetto con il sensore di temperatura e il display, cioè volevo fare un termometro, e sul display mi indicasse la temperatura che c'è nel ambiente dove si trova. Ma io non so da dove iniziare, sopratutto non so fare i collegamenti con LCD e arduino!
Ditemi tutto quello che occorre sapere.
Visto che mi avete sempre aiutato nei miei piccolo progetti volevo una mano anche in questo.

Michele Menniti

googla Arduino e LM35 e trovi schemi e sketch pronti all'uso; poi però mi permetto di darti un consiglio: cerca sul PlayGround "Display LCD" o "Liquid Crystal" e poi cerca "LM35", e troverai due articoli separati, ci perderai un po' di tempo, però poi avrai imparato a fare qualcosa di tuo seppur soltanto miscelando due tutorial, altrimenti sarai sempre bloccato dal complesso "pappapronta". Da quando, con questo espediente, ho realizzato uno stand-alone con tastiera esadecimale e display LCD (20x4), ho trovato lo stimolo ad iniziare tentando di fare quel che posso da solo, e poi magari chiedo al Forum di aiutarmi a risolvere gli inghippi. :)
Guida alla programmazione ISP e seriale dei micro ATMEL (Caricare bootloader e sketch):
http://www.michelemenniti.it/Arduino_burn_bootloader.php
Guida alla Programmazione ATmega328 noP:
http://www.michelemenniti.it/atmega328nop.html
Articoli su Elettronica In:
http://www.michelemenniti.it/elettronica_in.html

alberto39

Ciao Michele grazie, ho collegato il sensore di temperatura ad arduino e a quando ho capito il pin centrale e quello del segnare
e altro è alimentatore e altro ancora e la massa, ora una volta collegato ha funzionato poi ho scollegato tutto per cambiare pc e collegando di nuovo mi fa fumo e si riscalda molto i collegamenti sono sicuro che sono giusti sia nel primo caso che nel secondo caso ho collegato il sensore al pin dei 5v e l'arduino è alimentato da porta usb. MI sapete dire cosa può essere successo, ho perso il sensore? o arduino gli si è rotto un qualcosa? come posso vedere se arduino sta bene?

lo schema del collegamento lo ho preso da qua http://www.adrirobot.it/sensori/lm35/scheda_arduino_lm35.htm

pelletta

Cosa fumava, il sensore o l'arduino?
Scollega tutto e prova a caricare qualche sketch, il blink ad esempio; se lo carica prova ad usare il pin dove era collegato il sensore.

alberto39


Cosa fumava, il sensore o l'arduino?
Scollega tutto e prova a caricare qualche sketch, il blink ad esempio; se lo carica prova ad usare il pin dove era collegato il sensore.


si si scusa il sensore fumava, ma il sensore io lo ho collegato ne uscita A0, gli posso collegare un led li??

pelletta

Certamente, però ricordati di mettere una resistenza sul led.
Poi prova sempre il blink ma imposta il pin A0 come digitale 14, in questo modo si accenderà il led su A0 (cambia il 13 sullo sketch e metti 14).
Gli ingressi analogici possono anche essere usati come pin digitali, quindi A0 diventa digitale 14 e A5 diventa digitale 19.

Michele Menniti

Alberto, la prima volta che ho usato l'LM35 ha fumato pure con me, c'ha proprio il vizio :smiley-sweat: avevo invertito il V+ con l'uscita o qualcosa del genere, ti garantisco che Arduino non ha subito alcun danno, se non altro perché lo alimenti a 5V, come il sensore; e posso assicurarti che se non l'hai tenuto in quelle condizioni per più di un minuto il sensore funziona ancora, quindi abbi un po' di fiducia e riprova ma attenzione ai collegamenti, sono sicuramente sbagliati
Guida alla programmazione ISP e seriale dei micro ATMEL (Caricare bootloader e sketch):
http://www.michelemenniti.it/Arduino_burn_bootloader.php
Guida alla Programmazione ATmega328 noP:
http://www.michelemenniti.it/atmega328nop.html
Articoli su Elettronica In:
http://www.michelemenniti.it/elettronica_in.html

alberto39

#7
Nov 09, 2012, 10:00 pm Last Edit: Nov 09, 2012, 10:03 pm by alberto39 Reason: 1

Certamente, però ricordati di mettere una resistenza sul led.
Poi prova sempre il blink ma imposta il pin A0 come digitale 14, in questo modo si accenderà il led su A0 (cambia il 13 sullo sketch e metti 14).
Gli ingressi analogici possono anche essere usati come pin digitali, quindi A0 diventa digitale 14 e A5 diventa digitale 19.


si si il led funziona, questo che vuol dire??

alberto39


Alberto, la prima volta che ho usato l'LM35 ha fumato pure con me, c'ha proprio il vizio :smiley-sweat: avevo invertito il V+ con l'uscita o qualcosa del genere, ti garantisco che Arduino non ha subito alcun danno, se non altro perché lo alimenti a 5V, come il sensore; e posso assicurarti che se non l'hai tenuto in quelle condizioni per più di un minuto il sensore funziona ancora, quindi abbi un po' di fiducia e riprova ma attenzione ai collegamenti, sono sicuramente sbagliati


non mi ha lasciato perchè lo ha fatto tanto tanto fumo e poi era molto caldo infatti ora che lo ricollegato fuma ancora di più è morto menomale che mi è costato 1.50euro

Michele Menniti

allora lo hai tenuto acceso parecchio, io ricordo che ho prima sentito il cassico odore di elettronica arrosto, poi ho tolto l'alimentazione ed il sensore bruciava proprio però effettivamente fumo non ne ricordo, comunque di sicurto hai invertito due poli tra loro, quindi fai attenzione al prossimo che prendi
Guida alla programmazione ISP e seriale dei micro ATMEL (Caricare bootloader e sketch):
http://www.michelemenniti.it/Arduino_burn_bootloader.php
Guida alla Programmazione ATmega328 noP:
http://www.michelemenniti.it/atmega328nop.html
Articoli su Elettronica In:
http://www.michelemenniti.it/elettronica_in.html

alberto39


allora lo hai tenuto acceso parecchio, io ricordo che ho prima sentito il cassico odore di elettronica arrosto, poi ho tolto l'alimentazione ed il sensore bruciava proprio però effettivamente fumo non ne ricordo, comunque di sicurto hai invertito due poli tra loro, quindi fai attenzione al prossimo che prendi


ora lascio tutto perchè ho paura di fare altri danni :smiley-roll-sweat:
Michele mi spieghi come devo collegare il mio lcd cioè è come la leonado senza i headers cioè ci sono solo i buchi i non i cosi neri?
E questo http://www.robotstore.it/product/436/Display-LCD-16x4-retroilluminato-BLU-driver-SPLC780D.html

Michele Menniti

intanto dimentica collegamenti con fili innestati nei fori, serviranno solo a farti impazzire; o saldi i fili direttamente nei fori, oppure saldi dei pin nei fori prevedendo poi di innestarli in una fila di header sul PCB che andrai a realizzare, oppure saldi nei fori una fila di header (uguale a quella che hai messo alla Leonardo) e poi colleghi tutto mediante cavetti jumper maschio-maschio
Guida alla programmazione ISP e seriale dei micro ATMEL (Caricare bootloader e sketch):
http://www.michelemenniti.it/Arduino_burn_bootloader.php
Guida alla Programmazione ATmega328 noP:
http://www.michelemenniti.it/atmega328nop.html
Articoli su Elettronica In:
http://www.michelemenniti.it/elettronica_in.html

alberto39


intanto dimentica collegamenti con fili innestati nei fori, serviranno solo a farti impazzire; o saldi i fili direttamente nei fori, oppure saldi dei pin nei fori prevedendo poi di innestarli in una fila di header sul PCB che andrai a realizzare, oppure saldi nei fori una fila di header (uguale a quella che hai messo alla Leonardo) e poi colleghi tutto mediante cavetti jumper maschio-maschio

come si fa a saldare i header nei fori ?

Michele Menniti

allo stesso modo della Leonardo, non lo hai già fatto?
Guida alla programmazione ISP e seriale dei micro ATMEL (Caricare bootloader e sketch):
http://www.michelemenniti.it/Arduino_burn_bootloader.php
Guida alla Programmazione ATmega328 noP:
http://www.michelemenniti.it/atmega328nop.html
Articoli su Elettronica In:
http://www.michelemenniti.it/elettronica_in.html

alberto39


allo stesso modo della Leonardo, non lo hai già fatto?


non io no ho la leonardo,non ho mai saldato, lo solo citata per far capire meglio come è la mia situazione  :smiley-roll-sweat:

Go Up