Go Down

Topic: Nokia 5110 (life or death ?..) (Read 881 times) previous topic - next topic

Maverik2210

Nov 10, 2012, 08:06 pm Last Edit: Nov 10, 2012, 10:03 pm by Maverik2210 Reason: 1
Hi, folks!

Need your help on subject display (red one, looks exacly as sparkfun).
Have received one a week ago and still trying to get it work properly...  8)
The issue is display works only occasionally, randomly shows designated images and text, but much more often i see just random flicker horisontal lines. Moreover, normal images or text appears usually on first wiring, the next or third attempt after reset may be faulty - while on first attempt i can see normal images between flickers, after power off/on it can be only flickers or nothing. So i do afraid that the issue is hardware...  8)  only LED works fine
Connection is to arduino nano 5 v as per sparkfun scheme for such devices i.e. via 10k resistors.

I've checked voltage and current on display and result seems to be a bit disappointing

PIN / Voltage / Current

VCC  /  3.28      
SCE   /  2.32   /  0.46
RST   /  0       /  0
D/C   /  2.28   / 0.45
DNK  / 4.57   / 0.47
SLK   / 4.57   / 0.47

is it almost dead ???  8)




MarkT

You can't get much meaningful from measuring voltages (or currents) of a high speed logic signals if they are changing - multimeters measure on a timescale of around a second, logic signals change upto 8 or 9 orders of magnitude faster than that.

How fast are you driving the signals ?  Is this hardware SPI?  How long are the wires?
[ I won't respond to messages, use the forum please ]

Maverik2210

solved using 4050 level shifter.

Go Up