Go Down

Topic: Can any one help me with this? (Read 838 times) previous topic - next topic

tuxduino


Nick Gammon


Code.
Schematics.


Don't get too excited. The OP hasn't responded to any questions or comments.

Quote
... im slowly getting frustrated and starting to consider just getting a new one ...


@OP:

Read this before posting a programming question

A thread title that describes what the problem is, is more helpful than: "Can any one help me with this?".

somethingElse


Are you trying to program the Arduino Uno with the LEDs connected?  Sometimes you may need to disconnect everything from the I/O pins so that it doesn't interfere with the uploading of sketches.




I just disconnected the board from the entire schematic and tried to upload the blink program, hoping pin 13 would blink repeatedly. It did not work. So, there is no schematic and the code is the same as the blink code. Upon further troubleshooting, I noticed that the Arduino software performs exactly the same when I completely disconnect the USB and ftdi. It runs through, gives the error message above, and then says "Done uploading.". It would appear it is not the FTDI, but something with either the software or system. I'm running the Lilypad Atmega328, (and tried two different lilypads, so it's not the board). It's also helpful to note, I am not the OP.

tuxduino

FWIW, I had a similar error in two occasions.
One was when I fried a 328.
The other was when the previous successfully loaded sketch was saturating the serial interface with continuous println()s right from the start.
In both cases I had an Arduino 2009. Never tried a Lilypad...

somethingElse

I got this to work. I've never had to install drivers using Arduino on a mac, but that was the issue. I went to sparkfun.com and downloaded the drivers for the ftdi basic.

Go Up