Go Down

Topic: Copernicus II (GPS), data reading problems! (Read 1 time) previous topic - next topic

mrShrimp

Note: I posted a similar topic in "project guidance", but I realize that this is a section more relevant to my problems (I hope!)

Hi!  I have purchased a Trimble Copernicus II GPS unit and I am trying to read its data on the serial monitor with an Arduino Uno.  The unit came soldered onto a board with leads for 5v RS-232 and 3.3v TTL level outputs.  I have tried hooking up the TTL output lead to the Uno's RX pin, but the serial monitor did not output anything.  I tried using the SoftwareSerial library with pin 10 receiving, but it made no difference.  I used this code during my testing:

Code: [Select]

byte aa;
void setup()
{
  Serial.begin(4800);
  Serial.println("It works, so far");
}

void loop()
{
  if (Serial.available()>0) // if there is data coming into the serial line
  {
    aa = Serial.read(); // get the byte of data
    Serial.print(byte(aa)); // send it to the serial monitor
  }
}


I don't understand why nothing is being outputted.  The GPS unit warms up when I apply power, and I can see that it updates itself every second by reading the data leads with a voltmeter.  Can I please have some help with this?  Thank you!

mrShrimp

FIXED:

This is odd.  The device is rated for 5 - 14 volts, I applied around 12.75v via external battery pack, but nothing showed up on the serial monitor.  When I tried powering the device through the Arduino's 5v pin, voila, it works :p.  Does anyone know why this happened?

fbriggs4

I looked at the GPS data sheet and it is rated for 2.7-3.3V. My guess is that the regulator on your eval board did not like the higher voltage that you were applying.

Go Up
 


Please enter a valid email to subscribe

Confirm your email address

We need to confirm your email address.
To complete the subscription, please click the link in the email we just sent you.

Thank you for subscribing!

Arduino
via Egeo 16
Torino, 10131
Italy