Go Down

Topic: Can't upload to Arduino Mega 2560 (Read 980 times) previous topic - next topic

mcremers

Nov 13, 2012, 12:15 pm Last Edit: Nov 13, 2012, 12:17 pm by mcremers Reason: 1
Hi,
I've recently bought an arduino 2560. I installed the correct drivers and selected the right COM-port and arduino in the arduino program.
However, when I want to upload a sketch to the arduino, nothing happens. It starts compiling the sketch and when it says uploading the loading bar freezes around 80% of the uploading and keeps saying 'uploading'. it doesn't give an error message or something but the sketch isn't uploading.

When I press reset on the arduino, the orange led (AREF) starts blinking. And when I want to try to upload it again it says:
COM-PORT already in use (sketch is still not uploaded.) I've read about the '!!!' bug. I don't have '!!!' in my sketch. I really don't know what to do or how to make it work.

I also tried uploading the sketch to my arduino UNO, and that works just fine..

I would really like to know what to do and how to make it work :)!
thanks for any response

Mcremers

eried


Hi,
I've recently bought an arduino 2560.


If the uno works just fine, I think you should return the 2560 because it is probably that there is something wrong with the board.
My website: http://ried.cl

z1snow

I am having a very similar problem with a SainSmart Arduino Mega 2560.  However, the arduino loader is not able to find the /dev/tty.usbmodem1d11 .

Are you able to find this port when you plug in the Arduino with the usb cable?

When I use an Arduino Mega from "Arduino" the port is correctly found and it works perfectly.

I have seen a thread saying that the usb cable can be finicky but I haven't been able to tweak the cable to get a different result....  :~

mcremers

When I plug in the arduino, it finds the port (COM13, using windows) just fine.

Could it be the cable? I doubt it.. but I will try.

I am borrowing an another arduino mega in a few days, going to try out if that one works well..
Maybe the arduino is broken.. I hope not.

mcremers

t'was indeed the arduino ;)
got another one now and everything works fine.. Thanks for response!

Go Up
 


Please enter a valid email to subscribe

Confirm your email address

We need to confirm your email address.
To complete the subscription, please click the link in the email we just sent you.

Thank you for subscribing!

Arduino
via Egeo 16
Torino, 10131
Italy