Go Down

Topic: power for rf module (Read 864 times) previous topic - next topic

thedovid

Ok, first post ever on this forum.  Please be nice.

I am using one of these cheap rf modules:
http://www.ebay.com/itm/1pcs-RF-transmitter-and-receiver-kit-for-Arduino-project-433Mhz-/370687915310?pt=LH_DefaultDomain_0&hash=item564eb8b52e

i have everything working just fine and dandy on my uno.  But I want to use the receiver with an atmega8 on a breadboard.  I uploaded the sketch and it works fine.  Then I tried unplugging it from the usb and using a 6v power supply  (4 AA battery pack).  Now it doesn't work.  Then I tried  2 2032 coin cell batteries.  Then it worked again!  I assume it has something to do with the voltage or current, but frankly, i have a really bad grasp of all of that.  The specs for the receiver say it uses 5v, but then why do the coin cells work?  I tried different resistors between the battery and the VCC pin on the receiver, but no luck.  (and yes, the AA batteries were fresh and working).

Any thoughts?

majenko

Can you post a schematic of your circuit so we can see how things are connected up?

thedovid

not much to show, but i attached an image anyways.

It's just the rf receiver connected directly to voltage, a digital pin on the microcontroller, and ground.

Like i said, everything works fine on usb power (through the FTDI bridge i use to upload sketches) and from the 2032 coin cells.

thank you.

majenko

That can't be the whole circuit - there's components missing.

retrolefty

Yes the mega8 needs more stuff to work then what you show, what is the clock source for the chip? How did you load the sketch into the mega8?

Lefty


thedovid

i'm using this:
http://cal-eng.com/?wpsc-product=atmega8_8mhz

So, really, that's the whole circuit (minus the led i use to indicate that a message is received)

When I upload sketches, I connect this:
http://cal-eng.com/?wpsc-product=ftdibridge-usb-serial-transceiver

But after that, I take it out and am left with a very simple circuit.

Like I said, it works with the coin cell batteries.  I had it sitting on one side of the room, by itself, blinking every time it received a message from the transmitter on the other side of the room.  I just don't want to rely on those small (and expensive) batteries for this project, and I'd like to understand what's happening so I can apply the knowledge to future endeavors for ever and ever.


majenko

My guess is that the coin cells have a lower internal resistance than the AA batteries, and thus can react to transients much faster, compensating for your lack of decoupling capacitors.

perhof

In addition to decoupling caps you should add a pull-up resistor on the reset pin.

thedovid

Majenko: can you explain decoupling caps?  What capacitors should i use?  Where do I put them?

Perhof: I use a pull-up resistor on the reset pin when I'm connected tot he usb module for uploading code.  Why would I need it during regular, stand-alone use, and how would it help me problem?

perhof

Leaving the reset pin unconnected leaves it floating.
The result could be random or continuous resets.

thedovid

ok.  What resistor should i use and where should i put it (from reset to...)?

Just to be clear- this simple setup has worked for me for other things- with the AA batteries, and no caps or resistors.
Which leads me to assume that the problem is something specific to using the rf receiver.

mauried

The problem is the 433 Mhz receiver, they are very critical on supply voltage.
They need 5V plus or minus 0.5 V.
They wont work on 6V.
The reason most likley that the coin cells work, is that they arnt designed for delivering much current, so its likley
the current the Mega8 is pulling is causing the cell voltage to droop a bit.
If you want they system to be reliable its best to run the receiver off 5 V regulated.

thedovid

Ah!  Thank you, mauried.  That makes sense.
So, could i just toss one of these into the circuit?
http://www.radioshack.com/product/index.jsp?productId=2062599&utm_source=Google&utm_medium=PPC&utm_term=2160509&utm_content=Exact&utm_campaign=PLA&cagpspn=pla

majenko

Not unless you want to add another battery.

The dropout voltage on one of those would put the incoming voltage at over 7V to get a 5V output.

To continue running from 6V you need a low dropout regulator.

thedovid

Ok, so I can use a 9v battery then, right?

Go Up