Go Down

Topic: Invalid device signature -ATtiny85 (Read 1 time) previous topic - next topic


It didn't start out this way. I have the Tiny85 breadboarded for programming and a new tube of 20 of the Tiny 85 chips. I have a new UNO R3 and am using arduino-1.0.2.  I took the first three chips in the tube and ran the bootloader on each of them with no problems at all. Over a two day period, I loaded sketches on each of them and used them in breadboarded circuits and they all worked fine. With changes to the different sketches, each chip went through the use cycle maybe four times each. Everything was ready to make another set of chips.

I loaded Arduino ISP into the UNO and then the bootloader to an Tiny85 @8MHz chip and got

avrdude: Device signature = 0x000000
avrdude: Yikes!  Invalid device signature

Everything I can think of checked okay and I tried and re-tried the chip but with the same results. 
I tried the next chip from the tube: same results.  The next chip: same results.  So with the next two chips...and with the last one in the tube. Not likely 8 dead chips!

I reset the UNO, reloaded the Arduino ISP, but with the same results. I put sketches on the UNO and they work fine. I made each of the UNO ports blink LEDs and the ports work.  I get a heartbeat LED blinking on pin 9 on the breadboard when the Arduino ISP is running.  I ran a backup copy of the arduino from another drive - same results.
I even replaced the ATmega328P-PU. Everything seems okay, just won't take the bootloader.

The ISP reports it is programming an ATtiny85
  The Arduino ISP is  v 04m3
    Avrdude is v5.11 compiled 9-2-2011
      using programmer  STK500 v1

I'm new at this, so any ideas would be most welcome.


Did you have Arduino IDE set to Tools->Board->Arduino UNO to upload the ArduinoISP sketch to your UNO?

Did you remember the capacitor between Reset & Gnd on the UNO after uploading the ArduinoISP?

Did you then set Board type to the Tiny85 you want to program empty bootloader to?

Did you burn the bootloader to set the Tiny85 fuses?

Wired up correctly?

Did you use File->Upload Using Programmer to load sketch onto Tiny85?


YES to all. The verbose dialogue prints that the bootloader goes a long way into the process and gets responses...then stops with the error msg.


This is a guess:
I have occasionally had the same problem. What I have done is to wriggle the tiny on the breadboard (and the other wires) to see if it is just a bad connection in the breadboard. Give it a try.


As some of the chips worked but not all I wonder if they have been programmed already (grey imports?) and need an external crystal as fuses have been set for that. Adafruit have an ArduinoISP2 that can supply a 8Mhz clock signal from an UNO pin that is maybe good enough to reset fuses.
Another possibility is the fuses have been set to disable Reset pin or ISP. I think you would need a high voltage programmer to fix this problem.

Go Up