Go Down

Topic: Invalid device signature -ATtiny85 (Read 1 time) previous topic - next topic

Vtube

I'm using a ZIF socket for the chips and did a continuity check with an ohmmeter to make sure each pin is working. Everything from the UNO pin to the ZIF pin works okay.
The bootloader simply tells me that it is working on a Tiny85 @8MHz, talks back and forth with it and then gives the error msg. The puzzling thing is that it worked smoothly the first three times and the UNO and that breadboard were unused while I fiddled around with the other stuff. When it didn't work on #4, I reset and reloaded and the bootloader seemed to be running okay... until it didn't.

As far as I know, the UNO is not going to change anything on the PC so those files should be okay and reloading the ISP should work.  The heartbeat light on pin 9 shows that the ISP is running; just the bootloader is weird.

Vtube


As some of the chips worked but not all I wonder if they have been programmed already (grey imports?) and need an external crystal as fuses have been set for that. Adafruit have an ArduinoISP2 that can supply a 8Mhz clock signal from an UNO pin that is maybe good enough to reset fuses.
Another possibility is the fuses have been set to disable Reset pin or ISP. I think you would need a high voltage programmer to fix this problem.


RIVA:  I looked at the chips under a magnifier and they are all marked ATmel ATtiny85-20PU.  The Mouser catalog only shows the max speed as being 20MHz. The 230 page data sheet lumps the tiny25/45/85 and I get lost in the details.  I will look at the Adafruit option and order another batch of theTiny85s and hope.  Thanks!

Still gonna keep trying, though 8)

Go Up