Pages: [1]   Go Down
Author Topic: Trouble Burning the Bootloader to Arduino Uno [SOLVED]  (Read 1037 times)
0 Members and 2 Guests are viewing this topic.
Offline Offline
Newbie
*
Karma: 0
Posts: 4
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Hey guys & gals,

I'm trying to burn the Arduino Bootloader to an Arduino Uno w/ the bootloader already on it (this is a process confirmation attempt before burning the bootloader to my own custom arduino board).

I've scoured the web and found some great tutorials that have led me no where; i feel i'm missing something simple here since I'm always getting the same message:

"avrdude: usbdev_open(): did not find any USB device "usb" "

Here's how i'm connected: USB-B from PC to AVRISP MKII, AVRISP MKII to Arduino Uno with ICSP standard connector, 5V barrel DC power source from the wall powering the Uno.

I go into the Arduino IDE (1.01) and select the Arduino Uno as the board and the AVRISP MKII as the programmer. Then I hit 'burn bootloader'. The above error message ensues.

I do not have avrstudio installed and I have the atmel (unsigned) driver isntalled. The AVRISP MKII pops up in my device manager with the yellow exclamation point as expected (so i've read).


What gives? I hope it's something simple!


Cheers,

Brian
« Last Edit: November 14, 2012, 10:56:36 pm by Riegerb » Logged

Global Moderator
Boston area, metrowest
Online Online
Brattain Member
*****
Karma: 538
Posts: 27139
Author of "Arduino for Teens". Available for Design & Build services. Now with Unlimited Eagle board sizes!
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

Fix your MKii driver.
This thread explains it well.
http://arduino.cc/forum/index.php/topic,118089.0.html
Logged

Designing & building electrical circuits for over 25 years. Check out the ATMega1284P based Bobuino and other '328P & '1284P creations & offerings at  www.crossroadsfencing.com/BobuinoRev17.
Arduino for Teens available at Amazon.com.

Offline Offline
Newbie
*
Karma: 0
Posts: 4
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

I followed this tutorial to the 'T' and no luck for both the 0023 & 1.01 Arduino IDE's. Same exact error message. Does this have any dependence on the COM port? I get this feeling i'm missing something simple...

thanks for the help!

brian
Logged

Global Moderator
Boston area, metrowest
Online Online
Brattain Member
*****
Karma: 538
Posts: 27139
Author of "Arduino for Teens". Available for Design & Build services. Now with Unlimited Eagle board sizes!
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

And the MKii driver is fixed?
Looks like this in Vista.

I use the MKii on 328Ps and 1284Ps a lot, has worked great since I fixed the driver.
Atmel Studio doesn't recognize it anymore tho.


* MKiiDriver.jpg (91.35 KB, 960x720 - viewed 29 times.)
Logged

Designing & building electrical circuits for over 25 years. Check out the ATMega1284P based Bobuino and other '328P & '1284P creations & offerings at  www.crossroadsfencing.com/BobuinoRev17.
Arduino for Teens available at Amazon.com.

Offline Offline
Newbie
*
Karma: 0
Posts: 4
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

I think you're on to my problem. I'm still getting the yellow exclamation point saying my driver is unsigned (although it also says it's working) but in this case i'm thinking AVRdude is not picking up the programmer. Are you using windows 7 by chance? It looks easy enough in XP or Vista as you pointed out but i'm finding lots of problems getting this to work on W7. I hope I don't have to partition an XP just to bootload a stinkin arduino!

Cheers!

Brian
Logged

Global Moderator
Boston area, metrowest
Online Online
Brattain Member
*****
Karma: 538
Posts: 27139
Author of "Arduino for Teens". Available for Design & Build services. Now with Unlimited Eagle board sizes!
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

I have Vista.  There have been some topics recently on getting the IDE to work in Win8, perhaps similar acceptance activity is needed for the driver.
Logged

Designing & building electrical circuits for over 25 years. Check out the ATMega1284P based Bobuino and other '328P & '1284P creations & offerings at  www.crossroadsfencing.com/BobuinoRev17.
Arduino for Teens available at Amazon.com.

Offline Offline
Newbie
*
Karma: 0
Posts: 4
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Thanks for the tip CrossRoads. The solution is actually really simple....

Reboot the PC (press F8) and select  'Disable Driver Signature Enforcement'. The driver will now be signed and working!

Needless to say it worked straight away with the Arduino IDE... I'm really surprised this solution is literally missing from the hundreds tutorials and videos... I had to look in the Windows 7 Developer forums for a fix to unsigned drivers..


Brian
Logged

Global Moderator
Boston area, metrowest
Online Online
Brattain Member
*****
Karma: 538
Posts: 27139
Author of "Arduino for Teens". Available for Design & Build services. Now with Unlimited Eagle board sizes!
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

Cool - I'll have to find a way to save that for future use with Win8 or whatever is on the next laptop I obtain  some time. Managed to miss 7 altogether smiley
Really need something faster for eagle card routing, this single centrino Sony Vaio really drags sometimes.
Logged

Designing & building electrical circuits for over 25 years. Check out the ATMega1284P based Bobuino and other '328P & '1284P creations & offerings at  www.crossroadsfencing.com/BobuinoRev17.
Arduino for Teens available at Amazon.com.

Offline Offline
Newbie
*
Karma: 0
Posts: 2
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Hi crossroads

thanks for the support, by the way I have a close related issue in this thread:
http://arduino.cc/forum/index.php?topic=73192.0

could you give some feedback on that?
(actually it is for the same project!)

thanks
Logged

Pages: [1]   Go Up
Jump to: