Go Down

Topic: DS18S20 - Bei Minustemperaturen ein Problem? (Read 999 times) previous topic - next topic

DE8MSH

Nov 15, 2012, 07:23 am Last Edit: Nov 15, 2012, 07:25 am by DE8MSH Reason: 1
Moin,

ich verwende derzeit die Lib hier http://www.pjrc.com/teensy/td_libs_OneWire.html für den DS18S20. Ich habe auch den Fix von "Known Bugs" gemacht mit dem unsigned Value. Es scheint aber weiter so, dass Minustemperaturen nicht angezeigt werden.

Siehe hier:



Es macht so einen "Hupfer". Ich kann mir nicht vorstellen, dass plötzlich Plusgrade sind. Zumal yr.no für die Zeit um 4 Uhr -4 Grad vorhergesagt hat un die Temperaturen meist stimmen  8).

Wie kann ich das Problem mit den "Minussen" lösen?

Bernd

Hallo,

bei uns war es kalt genug. Und die Fühler zeigen es auch an. Bei mir funktioniert es. Ich nutze allerdings OneWire und DallasTemperature zum auslesen

Bernd

DE8MSH

Danke Dir für den Hinweis. Gerade, als ich dachte ich schwenke mal auf die "Dallas Temperature" um, sehe ich

Code: [Select]
Supported Devices

    DS18B20
    DS1822
    DS18S20*
    DS1820

Additional devices can be implemented through different temperature strategies. Refer to the code for more information.
*Problems reported on this series


=( Näher beschrieben ist es aber nicht. Müsste den ganzen Serverkram vom Dachboden holen und den Fühler in dern Freezer legen um ihn zu checken. Das wollte ich mir sparen - muss aber wohl sein.


TransWarp

Da kann dir Kältespray helfen und richtig kalte Tatsachen schaffen zum messen.

Go Up