Go Down

Topic: avrdude:stk500:_getsync():not in sync: (Read 17968 times) previous topic - next topic


Hi I'm running 2 boards a USB Droid which works fine with the robot I've built and other projects and a UNO which recently started showing the following message - avrdude: stk500_get sync(): not in sync: resp = 0x00 ....... I'm able to choose the board Tools > Serial >com port 3 . verify & upload then the avrdude message is shown? The Blink code from examples won't upload either? none of the example code will upload at all, shows avrdude message every time. I'm running 1.0.2 (which is what I'm currently using) and have 1.0.1 still installed the problem persists with both versions if any one has experience with this sort of issue/can explain what's happening, help resolving this would be greatly apprieceated.


Have you tried the loopback test mentionned here http://arduino.cc/forum/index.php/topic,73748.0.html ?
What is the result ?
Is the led "L" blinking a few times when you reset your board ?


I started having this issue today after operating fine for the last week. Tried the loop back and that workd fine. but will not program the UNO 3.
My message is similar:
avrdude: stk500_getsync(): not in sync: resp=0x30

no tx or rx leds when upload is started
need help!


Nov 16, 2012, 04:04 am Last Edit: Nov 16, 2012, 04:18 am by elve96 Reason: 1
Hi thanks for the info, I tried the loop back instructions on the UNO I was having trouble with, nothing was echoed back via the serial monitor when testing the UNO also tested another board a USB DROID ( to check I was doing the test correctly) which worked fine. D13 LED does blink/flash a few times when reset is pressed after the test ie. jumpers removed,  From this do I draw the conclusion that the UNO is dead or is there something else that can be done to resolve this issue? 


I had this issue a couple of times and l it happened while unplugging and giving power to the arduino while other things plugged in.  I had to restart the computer this fixed it in both of my cases.


The problem is that the com port has changed. Check the Device Manager then check the compiler Tools/Serial Port; they should be the same.


Mar 21, 2013, 09:05 pm Last Edit: Mar 22, 2013, 01:56 pm by morvii Reason: 1
i have same proplem on my Arduino Ethernet W/ PoE + USB2SERIAL
did i wrong something
i am new user


hmm now i see this page http://scuola.arduino.cc/en/content/getting-started-arduino-ethernet
i download two file and  i replaced boards.txt file  form \arduino\arduino-1.5.2\hardware\arduino\avr
IDE 0022 or older  http://scuola.arduino.cc/sites/arduino/files/boards.txt.zip
IDE 1.0 Beta         http://scuola.arduino.cc/sites/arduino/files/boards1.txt.zip
and than i have new error ^^

   at processing.app.debug.BasicUploader.burnBootloader(BasicUploader.java:288)
   at processing.app.Editor$47.run(Editor.java:2524)
   at java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:209)
   at java.awt.EventQueue.dispatchEvent(EventQueue.java:597)
   at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:269)
   at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:184)
   at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:174)
   at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:169)
   at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:161)
   at java.awt.EventDispatchThread.run(EventDispatchThread.java:122)

IDE 0022 or older,  IDE 1.0 Beta these two items exactly give same error


Apr 02, 2013, 05:17 am Last Edit: Apr 02, 2013, 05:19 am by elve96 Reason: 1
Hi morvii

Have you tried the loopback test as mentioned above? if not go to http://arduino.cc/forum/index.php/topic,73748.0.html read it, follow the instructions carefully and give it a go, what is the result?  It is  also mentioned in another post that you may have a bridge possibly between the RX and 5V pins but were not sure?  Sometimes a bridged joint is very hard to see with the naked eye, try looking at the board with a photographers loop in good light ( under fluorescent light, at night works well for some people ).


Had this problem on my Windows machine. The problem was simply drivers. I had not installed the drivers for my Arduino yet.

Control Panel -> Device Manager

Right click on unknown device

Install drivers from location on my machine

Go to Arduino folder, select "drivers" subfolder.

Worked fine after that.


Hey guys..
I am getting exactly the same error.
I am trying to run ATmega 328 on breadboard. I uploaded the bootloader successfully. I'm following the procedure given on https://www.arduino.cc/en/Tutorial/ArduinoToBreadboard.
I am trying to build a circuit with external clock (16 MHz).
Please help me....!!


I'm also getting that same error.

I'm building a stand alone arduino whith a circuit to upload code via FTDI module.

in some forums thay say that this error happens when the chip hasn't got a bootloader burned in it, which in my case was possible because i got my ATmega328 chips off of ebay. so i successfully uploaded the bootloader by replacing the chip in the original arduino with the one i bought and used a Nano unit as ISP. and it worked (it loaded the blink example). However i Keep getting the same error.

Has anyone ever built an arduino on a breadbord with FTDI module as a programmer?

Go Up