Go Down

Topic: Serial Errors - Uno + Servo (Read 2209 times) previous topic - next topic

BBX

#15
Nov 17, 2012, 07:22 pm Last Edit: Nov 18, 2012, 12:05 am by BBX Reason: 1
Osgeld, thanks!
zoomkat, neat, I'll give that a try!

Edit:
I tried using a diode (replaced the red wire in image). The voltage went from 5.01V to 4.95V. Would the capacitors have anything to do with that. Also, then I wouldn't be able to use the 5.7V with the Arudino, right?
The image is just a generalization of how the circuit is laid out.

Thanks,
-BBX

zoomkat

You probably have something wired wrong. Also, using a 9v transistor battery to power a servo won't work for long. Replace the 9v battery with four ~1.5v batterys supplying ~6v directly to the servo like below. Radio shack has battery holders if needed.

Google forum search: Use Google Advanced Search and use Http://forum.arduino.cc/index in the "site or domain:" box.

BBX

#17
Nov 18, 2012, 12:44 am Last Edit: Nov 18, 2012, 12:46 am by BBX Reason: 1
x_x Sorry about that. I have a full 19V PSU for the system, but I couldn't find something like that in Fritzing, so I made two 9Vs to show ~18Vin.

Edit:
Didn't even think about parallel/serial. Sorry again for the confusion.

-BBX

Osgeld

Quote
I tried using a diode (replaced the red wire in image). The voltage went from 5.01V to 4.95V


the diode will do that, all diodes have a voltage drop across the junction... 0.7volts is a good generic guess, but the exact number depends on the exact diode, temperature, etc. Though the datasheet is usually pretty good about nailing it down.
http://arduino.cc/forum/index.php?action=unread;boards=2,3,4,5,67,6,7,8,9,10,11,66,12,13,15,14,16,17,18,19,20,21,22,23,24,25,26,27,28,29,30,86,87,89,1;ALL

BBX

I thought the idea was that adding a diode would increase the voltage at the 7805 around +0.7V?

Quote
You can add a small diode to the 7805 ground like below to up the 7805 output voltage to ~5.7v for better servo performance.


-BBX

zoomkat

Quote
I thought the idea was that adding a diode would increase the voltage at the 7805 around +0.7V?


That's correct. Check how you have the diode is installed. You may want to remove the 7805 from your circuit and get it setup standalone first. "Breadboard" drawings are not useful to me as I don't use breadboards (have a nice one, but never used it).
Google forum search: Use Google Advanced Search and use Http://forum.arduino.cc/index in the "site or domain:" box.

Go Up