Pages: 1 ... 3 4 [5]   Go Down
Author Topic: [SOLVED] Set Low Fuse Bit, Now Can't Program over ISP  (Read 5794 times)
0 Members and 1 Guest are viewing this topic.
United Kingdom
Offline Offline
Tesla Member
***
Karma: 227
Posts: 6637
Hofstadter's Law: It always takes longer than you expect, even when you take into account Hofstadter's Law.
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

Yep! That worked. I set the clock source (D9) from the Arduino  to 128KHz and connected it to XTAL2. After that, I went into AVR Studio and set the rate to 4.209KHz (or something very close) and the connection was very unstable. Though, I was able to set the fuses back to factory state after trying to write them a few times. Now it's working without the external clock source!

I'm glad you got it working. 4.2KHz was a little too high, that might be why it was unstable. Anyway, you should be back to using the internal oscillator divided by 8 now.

You might want to try a fuse setting that leaves CLKOUT enabled, such as 0xAE or 0xBF instead of 0xEE or 0xFF. That way you can easily check with your logic analyser that the resonator is oscillating.
Logged

Formal verification of safety-critical software, software development, and electronic design and prototyping. See http://www.eschertech.com. Please do not ask for unpaid help via PM, use the forum.

Pages: 1 ... 3 4 [5]   Go Up
Jump to: