Pages: [1]   Go Down
Author Topic: Ruined XBee 5V/3.3V Adapter trying to solder headers to it.  (Read 928 times)
0 Members and 1 Guest are viewing this topic.
Offline Offline
Full Member
***
Karma: 2
Posts: 221
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

I ruined XBee 5V/3.3V Adapter trying to solder headers to it. Any suggestions for assembled adapters? I think that Radio Shack has XBee Shield.
Logged

the land of sun+snow
Offline Offline
Faraday Member
**
Karma: 149
Posts: 2790
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

Many places sell XBee shields, adafruit, jameco, seeed studio, sparkfun, probably makershed.

What do you mean you ruined it? It's usually fairly easy to overcome soldering muckups. You had the
wrong kind of headers, ie not 2 mm?
Logged

Offline Offline
Full Member
***
Karma: 2
Posts: 221
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

The soldering iron's tip was too fat, making me put solder all over the adapter. I don't have soldering iron with skinny tip. I ruined the adapter trying to solder the 0.1" headers to the adapter. The 2mm headers were already soldered on the adapter at the factory. I need 5V/3.3V adapter with all headers already soldered to the adapter at the factory. If the 2mm headers aren't soldered to the adapter at the factory, I would solder the 0.1" headers to the adapter before soldering the 2mm headers to the adapter. The yellow LED doesn't light when I connect 5V and GND wires to the adapter.
Logged

the land of sun+snow
Offline Offline
Faraday Member
**
Karma: 149
Posts: 2790
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

First off, order a soldering iron with a smaller tip, preferably with a beveled tip, rather than
a conical tip. It's worth the price to spend $50 and get a heat-controlled, adjustable unit.

Also, even with the fat tip, you should be able to reheat all the solder joints that overflowed,
and draw off the excess solder. Once the solder has re-melted, pull the tip off to one side
of the joint, and the excess solder will follow. Surface tension. May need to repeat a couple
of times. It's not too difficult to do.

Be sure to wipe excess solder off of the iron tip on a damp sponge in between every single pass
at the board - this is very important. You also need to do this during normal soldering, or solder
globs will build up on the tip.

Do not power up until every solder joint is fixed and inspected.

« Last Edit: November 18, 2012, 12:39:01 am by oric_dan(333) » Logged

Seattle, WA USA
Offline Offline
Brattain Member
*****
Karma: 549
Posts: 46063
Seattle, WA USA
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

While you are getting a new soldering iron, some solder wick is cheap and oh-so-useful.
Logged

Offline Offline
Full Member
***
Karma: 2
Posts: 221
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

I ordered a XBee SIP adapter like this:

http://www.parallax.com/Store/Accessories/CommunicationRF/tabid/161/CategoryID/36/List/0/SortField/0/catpageindex/2/Level/a/ProductID/691/Default.aspx
Logged

Offline Offline
Full Member
***
Karma: 2
Posts: 221
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

I got the XBee SIP adapter in the mail today. If I connect one XBee to USB adapter and another XBee to SIP adapter with DOUT connected to DIN, and run X-CTU program, both XBees communicate with each other. I searched the Internet for Arduino and XBee tutorials and found one at http://www.jeremyblum.com/2011/02/27/arduino-tutorial-9-wireless-communication/ I found out that I need two XBee adapters. I took the XBee 5V/3.3V adapter and removed extra solder. I couldn't believe it that it worked with the X-CTU communication test. After connecting XBees to Arduino Unos, wiring up a pot to one board and a servo to other board, and uploading the code to the boards, I turned the knob and nothing happened to the servo. If I run the Serial Monitor connected to the board with the pot, I see values change when I turn the knob. If I run the Serial Monitor connected to the board with the servo, I don't see anything on the monitor. The video in the tutorial didn't have captioning. I think that I didn't set up the XBees to communicate with each other. Any suggestions?
Logged

the land of sun+snow
Offline Offline
Faraday Member
**
Karma: 149
Posts: 2790
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

First off, you cannot connect the XBee to the Rx,Tx [pins 0,1] at the same time as using
the USB port, as they conflict. You can disable the USB port by running the board off an
external battery.

Secondly, the XBee is a 3.3V only device, so you need to check if the adaptor you have has
5V to 3.3V level-translators. Some do, some don't.

Thirdly, you should not be trying to run a servo off of the 5V output pin of an Arduino board,
as the servo current can overload the voltage regulator, especially on bds with tiny smt
v.regs. Best to use a separate battery for the servos.
Logged

Offline Offline
Full Member
***
Karma: 2
Posts: 221
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

I don't know why Jeremy Blum didn't use the SoftwareSerial library. I didn't know that I can't use Arduino's Rx and TX pins when the board is connected to USB.
Logged

Offline Offline
Full Member
***
Karma: 2
Posts: 221
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

I found out that a part on the XBee 5V/3.3V Adapter almost came off. I need $28 plus shipping for another XBee SIP adapter.
Logged

the land of sun+snow
Offline Offline
Faraday Member
**
Karma: 149
Posts: 2790
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

If you mean a part on the NEW adaptor you just bought already came off [although I cannot imagine
this happening], then you should return it to the vendor.

Also, you can get the same thing much cheaper, eg  - http://www.adafruit.com/products/126

Also, these things are adaptors and not shields, if that's what you were after.
Logged

Offline Offline
Full Member
***
Karma: 2
Posts: 221
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

I meant the XBee 5V/3.3V Adapter that I ruined trying to solder the headers on it. The XBee SIP adapter is "plug-and-play" ready instead of a kit.
Logged

Pages: [1]   Go Up
Jump to: