Go Down

Topic: Official WiFi shield Network Scan problem (Read 2 times) previous topic - next topic

ddod

The Arduino WiFi shield seems to work fine on our corporate g only routers (well they are a/g).  It does occasionally have an issue connecting but that seems rare.  The sample code worked as is.  I wish I could give you more.  We did try the DFRobot wifi shield and it did not work at all for us.

davebudd

I have tried every setting on my router (E4200) which allows a/b/g/n mixed etc but ScanNetworks only rarely finds it. All other WiFi devices at varying ranges find it with no problem.

@ddod The DFrobot link was for instructions on how to upgrade the firmware using windows (not for their Wifi product). It is the only reference out there for the process of upgrading the firmware (and it didn't work - see original post). I think it's pretty poor that there is no official published process for windows on the arduino site.

Thanks to everyone for contributing your suggestions but I don't think anyone can blame me for sending it back (which I have now done).
I am reading good things about Imp and there is an Uno shield for them too (plus the Imp + shield is cheaper than the Arduino WiFi shield). It maybe that it is not as flexible, but given all I want is a simple client connection it looks very inviting.

LaurenPan

@davebudd
Now I've updated the post. I've uninstalled the flip to simulate the problem you met with. And install the flip again to test on my wifi shield sucessfully!
Please check the links for downloading the flip from ATMEL.
@ddod
If possible, please try it again. Even if there're some other problems, please leave a reply on the DFRobot link. I will follow this case and make it clearer!

yojimbo0

I am new to the Arduino scene and I am experiencing this same problem with the wifi shield.  Am I correct in assuming that a successful firmware update will fix this issue?

pylon

I would expect that shield delivered recently to have up-to-date firmware and not version from 2012.

What your router's setting? Post more information.

Go Up