Pages: [1]   Go Down
Author Topic: probleem met voeding  (Read 2452 times)
0 Members and 1 Guest are viewing this topic.
Belgium
Offline Offline
Jr. Member
**
Karma: 11
Posts: 94
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Hey iedereen,

Eerst en vooral een korte schets... Ik heb een Mega 2560 met welke ik een Hydro Controller gebouwd heb.
De code en specs vinden jullie hier op het forum...
Alles werkt perfect zoals het hoort. Alleen wanneer ik de Mega aansluit op een 9V voeding en dus niet via USB van spanning voorzie word er niets weggeschreven naar de SD kaart. Alle andere functies werken, voor zover ik kan zien, zoals het moet...
Ik heb reeds met verschillende voedingen getest. (6V, 9V & 12V)

Is er hier iemand die mij hier mee kan helpen?

mvg Billie
Logged

Global Moderator
Netherlands
Offline Offline
Shannon Member
*****
Karma: 224
Posts: 13917
In theory there is no difference between theory and practice, however in practice there are many...
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

hoeveel amps kan de voeding leveren?

heb je een voltmeter om de werkspanning(?) te meten?
Logged

Rob Tillaart

Nederlandse sectie - http://arduino.cc/forum/index.php/board,77.0.html -
(Please do not PM for private consultancy)

Belgium
Offline Offline
Jr. Member
**
Karma: 11
Posts: 94
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Alle voedingen die getest zijn hebben 1A.
Ik heb de lader van mijn gsm (5V/500mA) op de usb poort aangesloten en dit werkt dan weer wel...
Ik heb de indruk dat er iets mis is met de voltageregulator van mijn Arduino
« Last Edit: November 20, 2012, 01:53:29 am by BillieBricks » Logged

Global Moderator
Netherlands
Offline Offline
Shannon Member
*****
Karma: 224
Posts: 13917
In theory there is no difference between theory and practice, however in practice there are many...
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

wordt ie heel heet?
Logged

Rob Tillaart

Nederlandse sectie - http://arduino.cc/forum/index.php/board,77.0.html -
(Please do not PM for private consultancy)

Belgium
Offline Offline
Jr. Member
**
Karma: 11
Posts: 94
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Nee, staat al een paar dagen continu te draaien en niets op de mega voelt heet aan...
Logged

Forum Moderator
Belgium
Offline Offline
Edison Member
*****
Karma: 68
Posts: 1926
Arduino rocks; but with my plugin it can fly rocking the world ;-)
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

Als je veel stroom verbruikt kan je best een USB kabel doorsnijden en een 5 voeding op basis van een schakel regelaar (switching regulator in het engels) op aansluiten.
Gewoon de 5+ pin voeden lukt ook maar als je dan een USB kabel naar je computer insteekt krijg je problemen.
Als je een USB kabel gebruikt kan je geen 2 voedingen tezelfdertijd gebruiken.

Ik heb heel rare dingen gezien met de mega 2560 en voedings problemen. Als ik die poste heb ik nooit een zinnig antwoord gekregen. Ik sta dus niet echt te kijken maar ik weet ook niet wat het is.
Ik voed mijn robot (met mega 2560) nu dus via een batterij -> schakel regelaar -> USB kabel en sindsdien heb ik geen problemen meer gehad.
Met vriendelijke groet.
Jantje
Logged

Do not PM me a question unless you are prepared to pay for consultancy.
Nederlandse sectie - http://arduino.cc/forum/index.php/board,77.0.html -

Belgium
Offline Offline
Jr. Member
**
Karma: 11
Posts: 94
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

thx voor de info jongens (en meisjes smiley-wink )
Ik ben uiteindelijk een usb lader gaan kopen en voorzie de mega van spanning via de usb connector. Daar ik enkel bij het updaten van de sketch de usb poort nodig heb kan ik hiermee wel leven.
Van de voeding die de relay aanstuurt heb ik de ground verbonden met de ground van de mega. Dit blijkt stabiel te werken. De SD module werkt nu zoals het hoort...en alle sensorwaardes worden netjes weggeschreven

mvg Billie
Logged

Global Moderator
Netherlands
Offline Offline
Shannon Member
*****
Karma: 224
Posts: 13917
In theory there is no difference between theory and practice, however in practice there are many...
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Quote
Van de voeding die de relay aanstuurt heb ik de ground verbonden met de ground van de mega.
Dat is zelfs noodzakelijk om een gezamelijke referentie spanning 0V te hebben.
Logged

Rob Tillaart

Nederlandse sectie - http://arduino.cc/forum/index.php/board,77.0.html -
(Please do not PM for private consultancy)

Belgium
Offline Offline
Jr. Member
**
Karma: 11
Posts: 94
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

yup, dat had een collega van me ook uitgelegd. smiley-wink
Logged

Pages: [1]   Go Up
Jump to: