Go Down

Topic: Arduino UNO and Arduino Motor Shield and a 200 ohm potentiometer (Read 593 times) previous topic - next topic

fofro

Hi!

I'm having trouble to read the voltage value of the potenciometer's wiper "leg".

I connected it to the 5V-GND of the Arduino, and connect the wiper into A0 analog pin. At 100ohms, I should have read 2.5V, but instead, I got 0,49V! I'm using Matlab instead of IDE.
I set the A0 pin in two different ways to see if it was a syntax error :

pinMode(A0,'input') and pinMode(14, 'input');
potencmt=a.analogRead(0)/1023*5

but none worked as supposed.Therefore, I connected the Arduino's 5V to A0 to see if I would get 5V, no problem. But with the potentiometer it's inconsistent.

Do I really have to set A0 as input(I believe I dont) in order to "tell" Arduino to increase its impedance?
Do I need to use any special potenciometer functions to read the values?(I believe I dont either)

This is the script I have been trying to run:

Function motor

a=arduino('COM3')

    a.pinMode(12,'output');        %DIR A
    a.pinMode(13,'output');        %DIR B
    a.pinMode(9,'output');         %BRAKE A
    a.pinMode(8,'output');         %BRAKE B
    a.pinMode(3,'output');         %PWM A
    a.pinMode(11,'output');        %PWM B
    a.pinMode(14,'input');         % ??

b=0;

    while(b==0)
       
        a.digitalWrite(12,1); %
        a.digitalWrite(9,0);
        a.analogWrite(3, 255); 
 
        pause(5);

        potmcmt=a.analogRead(0)/1024*5

        a.digitalWrite(9,1);
        pause(5);
         
        a.digitalWrite(12,0);       
        a.digitalWrite(9,0);
        a.analogWrite(3, 255);       
   
        pause(5);                   
end
end

But the values returned by a.analogRead(0) don't correspond to the ones read by the multimeter


Go Up
 


Please enter a valid email to subscribe

Confirm your email address

We need to confirm your email address.
To complete the subscription, please click the link in the email we just sent you.

Thank you for subscribing!

Arduino
via Egeo 16
Torino, 10131
Italy