Go Down

Topic: [solved] Error while compiling neural network example code from hobbizine (Read 659 times) previous topic - next topic

Hi everybody,

I've been trying to learn a bit about neural networks, and I found some code that I'd like to experiment with. Unfortunately, I'm unable to compile it, and I can't figure out what the problem is. If anybody has any ideas, suggestions, or even a solution, I'd really appreciate your input.

I'm using Arduino 1.0 on Linux Mint 12 32-bit.

I tried to post the code directly, but I reached the maximum allowed character count. The code can be found at the bottom of this website: http://robotics.hobbizine.com/arduinoann.html

The error I'm getting is:
Quote

ArduinoANN.cpp: In function 'void loop()':
ArduinoANN.cpp:250:1: error: unable to find a register to spill in class 'POINTER_REGS'
ArduinoANN.cpp:250:1: error: this is the insn:
(insn 449 448 452 38 ArduinoANN.cpp:180 (set (reg:SF 130 [ D.3575 ])
       (mem/s:SF (post_inc:HI (reg:HI 154 [ ivtmp.316 ])) [10 HiddenDelta S4 A8])) 877 {*movsf} (expr_list:REG_INC (reg:HI 154 [ ivtmp.316 ])
       (nil)))
ArduinoANN.cpp:250: confused by earlier errors, bailing out

el_supremo

It compiles without error on 1.0.1 and Windows 7 Pro 64-bit.

Pete

I just downloaded Arduino 1.0.2 and now it compiles just fine. I wish I would have thought to check for a newer version before I posted.

Thanks for your help!

Go Up
 


Please enter a valid email to subscribe

Confirm your email address

We need to confirm your email address.
To complete the subscription, please click the link in the email we just sent you.

Thank you for subscribing!

Arduino
via Egeo 16
Torino, 10131
Italy