Go Down

Topic: DHT11 Woes (Read 1 time) previous topic - next topic


Have a DHT11 plugged in and feeling silly

long story short I have tried 3 different libraries (1 on arduino.cc, 1 on adafruit, 1 on github)
and Serial.print for the raw data received from the sensor and always 0's or 255 (255 might have been a fluke since it only showed once on the github library)

errors reported have mostly been timeout errors, with general fault and invalid value thrown into the mix at various configurations

so far it's all been attempted through various digital ports on the Arduino

DHT11 has 4 pins

  • 1 = power

  • 2 = signal (tried port 1-13) (with 10k jumper from power)

  • 3 = dummy

  • 4 = ground

still a greenhorn at writing Arduino code and this is the first sensor I've tried plugging in -- any ideas what I might be missing or data that I haven't reported that would be helpful in finding what direction to be looking?

thanks in advance


It is definitely not your code. Look somewhere else.



Have you tried this library and code - http://www.arduino.cc/playground/Main/DHTLib/ - it has been tested with DHT22 and DHT11 on duemillanove, UNO and MEGA.

Be aware that the DHT11 needs 2 seconds between sampling (google for datasheet)
Rob Tillaart

Nederlandse sectie - http://arduino.cc/forum/index.php/board,77.0.html -
(Please do not PM for private consultancy)


A quote from the playground article:

There have been reports that some sensors have pin 3 and 4 reversed, probably as a quality control/manufacturing issue. If you have issues, consider grounding both pins 3 and 4.

Have you tried that?


Just tried grounding pins 3 &4 together -- same result

running the library from http://www.arduino.cc/playground/Main/DHTLib/
it returns bGlobalErr = 1 (Start condition not met)

if I disable that section then it spits out Error 3: DHT Checksum Error

beginning suspect the Arduino Uno I'm working with may be faulty as I've tried 2 different DHT11's and get the same result

any other ideas to debug are appreciated

Go Up