Go Down

Topic: Arduino Due + Atmel Studio 6 Flash Problem (Read 1 time) previous topic - next topic



I'm using the Arduino Due with Atmel Studio 6 and I have found a major issue. If I leave the board powered down for > 1 minute, when I power it back up, it fails to read the internal flash memory. As a test, I wrote a byte to a fixed location in flash. Then the first thing I do in my main code is read the location, and if it is not as programmed, I flicker the LED. I get consistent results with 2 Arduino Due boards, whereby after powering the device off for > 1 minute, when I next power up the LED flickers to indicate that the flash was not read correctly.

I have also used Atmel's ASF Flash Programming Example code to reproduce this problem, to rule out anything stupid.

It works fine on my SAM3X-EK dev board, and I'm wondering if it's a start-up time issue. When I have used AVR's, I would set the SUT fuse to increase the start-up time, but with the ARM, I can't think of anything else I can do other than waiting for the clocks to stabilise?

Is anyone else using the Due and Atmel Studio 6, and if so is this something you have tried or will be trying?




I'm using the Arduino Due with Atmel Studio 6

Does this issue exist if you use the IDE?
The art of getting good answers lies in asking good questions.


I've only tried it using Atmel Studio IDE. I contacted Atmel to ask about this but I'm still waiting for a reply, so hopefully they will be able to reproduce it.

Go Up