Pages: [1]   Go Down
Author Topic: RUNNING A PROGRAM  (Read 738 times)
0 Members and 1 Guest are viewing this topic.
DELHI
Offline Offline
God Member
*****
Karma: 7
Posts: 821
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

I HAVE SIMPLE PROGRAM IN MAC WRITTEN IN V1.0.1 IDE VERSION MAC
I WANNA DOWNLOAD SAME PROGRAM IN TO WINDOWS XP USING V 1.0.1 IDE FOR XP

I CAN ABLE TO DOWNLOAD THE PROGRAM IN BOTH WITHOUT ANY ERROR

PROB:  CODE SIZE HAS INCREASED TWICE IN WINDOWS XP(IF MAC READING 4K, WITH WINDOWS SHOWING 8K)
MAC SHOWING PROPER ANSWER IN SERIAL MONITOR
WINDOWS XP SHOWING NOTHING ON SERIAL MONITOR

PLEASE LET ME TROUBLE SHOOT ANSWER FOR THIS
Logged

AMPS

Global Moderator
UK
Offline Offline
Brattain Member
*****
Karma: 302
Posts: 26280
I don't think you connected the grounds, Dave.
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Please don't SHOUT.

Quote
I HAVE SIMPLE PROGRAM
Which, it appears, you are not ready to share with us.
« Last Edit: November 17, 2012, 08:20:06 am by AWOL » Logged

"Pete, it's a fool looks for logic in the chambers of the human heart." Ulysses Everett McGill.
Do not send technical questions via personal messaging - they will be ignored.

UK
Offline Offline
Shannon Member
****
Karma: 223
Posts: 12631
-
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Can you upload the simple 'blink' example sketch from your Windows XP PC and confirm that it actually runs on the Arduino?
Logged

I only provide help via the forum - please do not contact me for private consultancy.

DELHI
Offline Offline
God Member
*****
Karma: 7
Posts: 821
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

yes i tried simple blink program from XP they are working
Logged

AMPS

UK
Offline Offline
Shannon Member
****
Karma: 223
Posts: 12631
-
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

In that case I suspect the problem is that you have not selected the correct serial port or port settings for the serial monitor. The settings in the monitor window need to be the same settings that your sketch uses to initialise the serial port on the Arduino. If you can't see the problem there then I suggest you post your code (in its entirety, using [ code ] [ /code ] tags) and also say what port settings you are using in the serial monitor.
Logged

I only provide help via the forum - please do not contact me for private consultancy.

DELHI
Offline Offline
God Member
*****
Karma: 7
Posts: 821
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

here  i am attaching code i wanna test. I know that Arduino uno has single Serial port . but it is possible to read the serial value though harware port

Code:
#include <SoftwareSerial.h>

SoftwareSerial ss(8,9);

void setup()
{
 Serial.begin(9600);
  ss.begin(9600);
 
}


void loop()
{
  ss.print(Serial.read());
  delay(1000);
}
this program has worked for me  for both in MAC and windows run Individually. when tried to download MAC  program in to arduino through windows xp IDE they are not working.
i wanna know what  make not to run program. since they are simple c program. If i copy the MAC os IDE program ( Ex: BLINK program ) and paste it on Windows xp IDE of arduino, and upload it then it working


Moderator edit: The usual smiley-sad


« Last Edit: November 19, 2012, 08:21:22 am by AWOL » Logged

AMPS

UK
Offline Offline
Shannon Member
****
Karma: 223
Posts: 12631
-
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

This sketch does not write anything to the hardware serial port, and you've told us nothing about what is connected to pins 8 & 9.

Step back from the problem - just write a sketch that initialises and prints something to the hardware serial port and confirm that it uploads and runs correctly on both platforms

At the moment it's impossible to guess whether you're chasing a bug in your code causing it to not do what you intend, or a problem such as pasting MBCS source code into an IDE that expects ASCII.
Logged

I only provide help via the forum - please do not contact me for private consultancy.

DELHI
Offline Offline
God Member
*****
Karma: 7
Posts: 821
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

here @ pin no 0 and 1 i am connecting gps receiver rX and tx pin

where as pin 8 an 9 i m connecting usb to TTl monitor . IN serial monitor i am selecting port refer to USB to ttl .

in below code i am reading data from Serial.port 0 and 1 and writing in to user defined hardware Serial port 8 and 9.



Logged

AMPS

Global Moderator
UK
Offline Offline
Brattain Member
*****
Karma: 302
Posts: 26280
I don't think you connected the grounds, Dave.
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Quote
in below code i am reading data from Serial.port 0 and 1 and writing in to user defined hardware Serial port 8 and 9.
Again please.
Logged

"Pete, it's a fool looks for logic in the chambers of the human heart." Ulysses Everett McGill.
Do not send technical questions via personal messaging - they will be ignored.

UK
Offline Offline
Shannon Member
****
Karma: 223
Posts: 12631
-
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

here @ pin no 0 and 1 i am connecting gps receiver rX and tx pin

where as pin 8 an 9 i m connecting usb to TTl monitor . IN serial monitor i am selecting port refer to USB to ttl .

in below code i am reading data from Serial.port 0 and 1 and writing in to user defined hardware Serial port 8 and 9.

While that's all possible, it's not what I would call simple. You started off describing what sounded like a fundamental problem, and I still don't know whether you're chasing a fundamental problem in the way you build and upload your sketch, or in the operation of the serial port, or a more complex problem in the way your sketch interacts with the various bits of hardware you're now introducing.

Please start with the basics: disconnecting all the extra hardware, if you upload a sketch that simply initialises and writes to the hardware Serial port, does this work correctly?
Logged

I only provide help via the forum - please do not contact me for private consultancy.

DELHI
Offline Offline
God Member
*****
Karma: 7
Posts: 821
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

please let me know basi test i need to do>>
Logged

AMPS

UK
Offline Offline
Shannon Member
****
Karma: 223
Posts: 12631
-
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

please let me know basi test i need to do>>

Which part of this did you not understand?

Please start with the basics: disconnecting all the extra hardware, if you upload a sketch that simply initialises and writes to the hardware Serial port, does this work correctly?
Logged

I only provide help via the forum - please do not contact me for private consultancy.

DELHI
Offline Offline
God Member
*****
Karma: 7
Posts: 821
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

please let me know basi test i need to do>>

Which part of this did you not understand?

Please start with the basics: disconnecting all the extra hardware, if you upload a sketch that simply initialises and writes to the hardware Serial port, does this work correctly?


yes it is working fine
Logged

AMPS

Pages: [1]   Go Up
Jump to: