Go Down

Topic: Arduino bruciato? Prove con 12V (Read 2 times) previous topic - next topic

astrobeed


Detto questo a me pare strano che possa essere la scheda, perché il fatto che sia correttamente riconosciuta dal PC significa che funzionano sia l'alimentazione che il micro convertitore USB-Seriale;


Per essere certi che l'adattatore USB-Seriale è funzionante basta mettere in corto tra loro i pin 0 e 1 (Rx e Tx), senza l'ATmega montato, aprendo la comunicazione con il terminale seriale tutto quello che viene inviato deve tornare indietro sotto forma di eco, se questo non avviene allora c'è un problema sul 8-16u2.

shinil35

L'avevo letto sull'inglese, tipo loopback? Ora provo..
Comunque si i chip che ho preso sono con bootloader dell'uno, ma proverò ugualmente a modificare le impostazioni nell'IDE!

Grazie a tutti, vi faccio sapere al più presto!

shinil35



Detto questo a me pare strano che possa essere la scheda, perché il fatto che sia correttamente riconosciuta dal PC significa che funzionano sia l'alimentazione che il micro convertitore USB-Seriale;


Per essere certi che l'adattatore USB-Seriale è funzionante basta mettere in corto tra loro i pin 0 e 1 (Rx e Tx), senza l'ATmega montato, aprendo la comunicazione con il terminale seriale tutto quello che viene inviato deve tornare indietro sotto forma di eco, se questo non avviene allora c'è un problema sul 8-16u2.



A quanto pare sarà questo il problema!
Perché collegandoli e mandandogli dei dati vedo il led RX che lampeggia ma poi non mi tornano indietro i dati!

Quindi mi tocca a cambiare arduino? :(

uwefed



Detto questo a me pare strano che possa essere la scheda, perché il fatto che sia correttamente riconosciuta dal PC significa che funzionano sia l'alimentazione che il micro convertitore USB-Seriale;


Per essere certi che l'adattatore USB-Seriale è funzionante basta mettere in corto tra loro i pin 0 e 1 (Rx e Tx), senza l'ATmega montato, aprendo la comunicazione con il terminale seriale tutto quello che viene inviato deve tornare indietro sotto forma di eco, se questo non avviene allora c'è un problema sul 8-16u2.


Per l' informazione: Si puó fare questo test anche senza dover togliere il ATMega328
ponticelli il pin reset con il pin GND e i pin TX con il pin RX.
Ciao Uwe

shinil35

Fatto sia con atmega che senza,
Seguendo questa guida:
http://arduino.cc/forum/index.php?topic=73748.0
E purtroppo non mi ritorna indietro nulla, ma quando scrivo lampeggia la luce dell'rx..

Go Up