Go Down

Topic: Arduino running under Parallels VM [solved] (Read 1 time) previous topic - next topic

James C4S

Running in a virtual machine doesn't have anything to do with your issue. 

Make sure you aren't making the mistake that many people do in windows and try to install the FTDI drivers.
Capacitor Expert By Day, Enginerd by night.  ||  Personal Blog: www.baldengineer.com  || Electronics Tutorials for Beginners:  www.addohms.com

davidhux

The Arduino Ide runs just fine - no problems so, yes, running in a VM is not the problem.

The issue is that it cannot see any Serial Ports, so cannot upload an app to the board.

I am unable to install any drivers (let alone the FTDI ).



davidhux

Problem solved - W8 dos not allow drivers without signatures to be loaded - you have to go into Settings and disable this feature.

see
http://www.bryonconnolly.com/windows-8-arduino-driver-install

mweber

It appears the Parallels VM reports a cut-off device ID.  Check the device ID in the device manager, then edit the inf file in the Arduino Driver subdirectory to show the same ID and it should now work.

Go Up