Pages: [1]   Go Down
Author Topic: Download of 1.0.2 for Mac OSX always generates "damaged" error and won't run  (Read 566 times)
0 Members and 1 Guest are viewing this topic.
Edmonds, WA USA
Offline Offline
Newbie
*
Karma: 0
Posts: 2
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

I have attempted to download the newest 1.0.2 version from the arduino.cc site and direct from Google Code site today and also tried a number of days ago. Download is for Mac and I am running OSX 10.8.2 on a MacBook Pro. Any time I download and try to run the software I get the following error and the app does not load/run in any way.

"'Arduino' is damaged and can't be opened."

I have not had any problem in using many past versions of the Arduino code on Mac and the prior version of 1.0.1 runs ok on OSX 10.8.2.

Anyone having problems with a corrupted download file from the arduino.cc site?
Is there something that has changed with 1.0.2 that would cause an error like this ("damaged") in the OSX environment?

Thanks.
Logged

Fort Lauderdale, FL
Offline Offline
Faraday Member
**
Karma: 71
Posts: 6144
Baldengineer
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

This is an issue with Gatekeeper.  You probably allowed a previous version of Arduino to run (right-click Open).  Now Gatekeeper thinks the Application bundle has been modified and refuses to launch it.

The solution is:
Turn off Gatekeeper (System Preferences -> Security & Privacy -> Allow Applications from Anywhere)
launch 1.0.2,
then turn it back on (whatever your Gatekeeper setting was before).
Logged

Capacitor Expert By Day, Enginerd by night.  ||  Personal Blog: www.baldengineer.com  || Electronics Tutorials for Beginners:  www.addohms.c

Edmonds, WA USA
Offline Offline
Newbie
*
Karma: 0
Posts: 2
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

James:

Thanks.
That was the issue.
Fixed. 1.0.2 runs fine now.
I appreciate the help.

Dave.
Logged

Pages: [1]   Go Up
Jump to: