Go Down

Topic: shifter register (Read 6814 times) previous topic - next topic


ok guess i will have to get me some capacitors


While adding decoupling is a good thing to do, I think that the problem is with your code.

The delay of 75 mills will with your data turn on each of your leds for 75 mills and then turn it off. This is so fast that all you would see (even if the hardware is ok) is a very faint glow on the led.

Try changing delay(75) to delay(2000). Than play around.



added the capacitor with no change. shift registers ares cheap enough i decided to order a new batch and try again. waiting for the new ones to come in


added the capacitor with no change.

Not surprising, :).

All I can tell you is that your code works. The problem is hardware.


added the capacitor with no change.

All I can tell you is that your code works. The problem is hardware.

He is wrong there is something wrong with both your hardware and your software.
Keep the capacitors, you still need them, the fact that it made no change means you have something else wrong as well. Up that delay and re check the wiring, especially power and ground.


new shift registers come in today. Will make sure to check all wiring as well as change the delay and see if it works.
really appreciate all the help so far.


I just tried your exact sketch (on the first page of this thread) with my 595 shift registers as pictured here, and it worked!

The wires to the Arduino are different because that is the same photo I took when I used SPI to transfer.

However, it proves the code is OK.

Thus it must be hardware.
Please post technical questions on the forum, not by personal message. Thanks!

More info: http://www.gammon.com.au/electronics


ok with the new shift register i can get it to work when i disconnect the latch pin from my arduino and it will run and then stop and then start again


running with pin 11 on the 595 to pin 3 on arduino pin 12 to + voltage and pin 14 to pin 2

Go Up