Pages: [1]   Go Down
Author Topic: ADXL345 problems: no data  (Read 465 times)
0 Members and 1 Guest are viewing this topic.
Offline Offline
Newbie
*
Karma: 0
Posts: 3
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Hello! I'm new with arduino and have some problems with the ADXL345 accelerometer: It only delivers 0 0 0 for x y z.

I tried several tutorials like http://www.babelduck.com/index.php/en/reference/user-manuals/1427-adxl345-3-axis-accelerometer-sensor-module-product-manual and http://bildr.org/2011/03/adxl345-arduino/ but with all of these my accelerometer seems to deliver only nulls...
I wired it up exactly like in the manuals.

It's brand new and it's hard to believe, that it's broken. Wiring was always like it should.

Anyone an idea?

Thank you so much!
Logged

Switzerland
Offline Offline
Faraday Member
**
Karma: 108
Posts: 5144
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Just to check: you have an Arduino UNO as used in the tutorials?
Logged

Offline Offline
Edison Member
*
Karma: 9
Posts: 1017
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

You should start with the i2c_scanner, to see if the device is detected : http://arduino.cc/playground/Main/I2cScanner
Logged

Offline Offline
Newbie
*
Karma: 0
Posts: 3
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Oh, that's really awkward... I've a Mega and didn't know that there I've to use other pins.

Sorry for that, I'm just a beginner. So thank you very much, now it runs like a charme!
Logged

Pages: [1]   Go Up
Jump to: