Pages: [1]   Go Down
Author Topic: Arduino Due + Virtual Wire  (Read 1647 times)
0 Members and 1 Guest are viewing this topic.
Offline Offline
Newbie
*
Karma: 0
Posts: 3
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset


Hey guys!

I just received the new Due and was trying to set up a simple sketch to transmit and receive data over RF.

Has someone figured out how to get the "Virtualwire" library working with the Arduino Due? I get the error code

/Applications/Arduino.app/Contents/Resources/Java/libraries/VirtualWire/VirtualWire.cpp:20: fatal error: util/crc16.h: No such file or directory

every time i try to compile a sketch.

Thank you!

Logged

Westbrook, CT
Offline Offline
Full Member
***
Karma: 2
Posts: 139
"Why should I bother with made-up games when there are so many real ones going on." (c) Kurt Vonnegut
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

Unfortunately I have the same problem with my Arduino Uno.I just received my 433Mhz RF transmitter and receiver pair but when I try to compile my sketch in the IDE it gives me a similar error. Even if I use the Examples! I think it's just the version of the Virtual Wire library that is outdated for the current Arduino IDE. (I have the 1.0.3 version and the recent Virtual Wire version is 1.5 which was written back in 2010 )  smiley-roll

SO VIRTUAL LIBRARY DEVELOPER, PLEASE FIX THIS!!!  smiley-roll-sweat smiley-mad
« Last Edit: March 15, 2013, 06:38:32 pm by mixania » Logged

Arduino Uno R3
Mac OSX Lion


Offline Offline
Newbie
*
Karma: 0
Posts: 13
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Your library version probably does not have the /util directory. Use the last version (1.15) and you will solve this problem. Even if I encountered in a next step another problem in the compilation phase. And I am still waiting for an help.
Ciao
francesco
Logged

Offline Offline
God Member
*****
Karma: 32
Posts: 507
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Could you try the possible fix I just posted in this thread: http://arduino.cc/forum/index.php/topic,150941.msg1177689.html#msg1177689

I have tried it between a Due and a Uno with a physical wire and that worked, but I have not tried radios yet.

Logged


Pages: [1]   Go Up
Jump to: