Go Down

Topic: HELP! problems with audio detection circuit (Read 984 times) previous topic - next topic

Hi! First off, thank you so much for any help. I am slowly learning electronics and arduinos etc... maybe one day I will be smart enough to help people on here.

I am attempting to build the audio detection circuit found here: http://www.picaxe.com/docs/picaxe_sound.pdf

I arranged it all on a breadboard and I thought I did everything perfect...
I am powering the circuit by the 5v from the arduino.
The output (0-3v) is connected to an led. presumably the led should turn on when the circuit detects sound.

It does not turn on at all no matter what sound is made. I have tried changing the sensitivity of the two potentiometers. I have also hooked up the output to a multimeter.
it reads 0.52v no matter what sound is made or setting of the potentiometers.

Here is a high quality picture of the set up. Since some of the pins under the transistors and capacitors cannot be seen, I drew them in orange: http://i50.tinypic.com/r877r6.jpg

here are a few more pictures at different angles:
http://i45.tinypic.com/33dcs1z.jpg
http://i48.tinypic.com/18omdv.jpg
http://i46.tinypic.com/28vrvgn.jpg


Let me know if you have anymore questions.

Thank you for any help!

James Hutton

dhenry

a few tips:

1) power it up for the first time through a 100ohm resistor, and measure the voltage over that resistor: this assures you if there is short.
2) you need to make sure that the dc working points are correct. Measure voltage on Q1's b / c, Q2's b/e/c, Q3's b/e. and compare them to what you expect. For example, Q1's b should be about 0.7v, Q2's b should float with RV2, etc.
3) if you have a scope, it would be helpful but get the dc working points and report back.



a few tips:

1) power it up for the first time through a 100ohm resistor, and measure the voltage over that resistor: this assures you if there is short.
2) you need to make sure that the dc working points are correct. Measure voltage on Q1's b / c, Q2's b/e/c, Q3's b/e. and compare them to what you expect. For example, Q1's b should be about 0.7v, Q2's b should float with RV2, etc.
3) if you have a scope, it would be helpful but get the dc working points and report back.




ok,

1) I measured the voltage over a 100r resistor in place of the led. It was 0v. I asume this is what you mean telling me there is a short.

2)    -i measured the voltage across q1. it reads 0.230mv from c-b, 0.6v from b-e and 0.85v from c-e.
       -q2: 4.5v from c-b, 5v c-e, 0.5v b-e
       -q3: 4.8v c-b, 5v c-e, 0v b-e

3) no scope :/

thanks!



dhenry

1) no idea what "led" you are talking about.

2) the voltage I was talking about was the respective points vs. ground.

dhenry

So Q1 is conducting, at about 0.8ma Ic. That's good.
Q2 is not conducting: RV2 is too small so you will need to raise the wiper towards the top (the rail).
As Q2 is not conducting, Q3 is not conducting.

dhenry

You need to raise RV2's wiper so that Q2's vbe goes towards 0.6-0.7v and Q3's base goes above 0.7v.


1) no idea what "led" you are talking about.

2) the voltage I was talking about was the respective points vs. ground.



1) i meant from the output (0-3v) to the ground.

2) oh ok, sorry.

      q1: b = 0.63v  c = 0.86v
      q2: b = 4.5-6.5v (depending on sound)   e = 5v   c = 0 - 3.5v (depending on sound) (the led lights up to sound from this pin to ground, but it doesnt have the slow decay which i am assuming is what the next transistor is for)

      q3: e = 0v (no matter what sound), b = 0v (no matter what sound) c = 0v (no matter what sound)

so I am assuming the problem is somewhere around the last transistor...


You need to raise RV2's wiper so that Q2's vbe goes towards 0.6-0.7v and Q3's base goes above 0.7v.


ok, the rv2 is at max and the vbe is 0.63v, but q3's base to ground is still like 300mv,

dhenry

If the circuit is powered at 4.5v rail, how can Q2's base go to 6v?

dhenry

In that event, R5 is too high. Get it down to ~100k.

i turned the diode around and it seems to work now. weird. i thought the black line was the cathode. doesnt it look right in the picture?

dhenry

The circuit will work only with the diode as connected (in the schematic).

You can check for the diode's polarity by measuring voltages on both ends.

oric_dan

OP, after you learn how transistors work, the next step is discovering that opAmp circuits
are a much better way to go, in general requiring far fewer components, and producing much
better results with a lot less effort,

http://www.google.com/search?&site=imghp&tbm=isch&source=hp&biw=1012&bih=811&q=electret+amplifier

However, it's always good to learn basic electronics, in any event.

Go Up