Go Down

Topic: uno rev3 16u2 firmware flashing with dfu-programmer (Read 6 times) previous topic - next topic

Ender_sD

#10
Dec 02, 2012, 06:49 pm Last Edit: Dec 02, 2012, 07:50 pm by Ender_sD Reason: 1
When I do that, the menu prints back out and the
Code: [Select]
no device present error is gone.  This is awesome, but no matter what combination of erase, reset, or flash (a different hex file) I do, even with the menu printing back after each command, the arduino still functions normally in the Arduino IDE and continues to appear as an Arduino in the port manager after each plug cycle, even though it appears as a "composite device" before I plug cycle it, and after I short the pins. (which would be when I perform the operations via dfu-programmer).  Any ideas?  Thanks for all your help nueh

edit: There is no atmega16u2 option when the menu prints, so when I am entering what you suggested I think the dfu-programmer menu is just reprinting because the terminal is recognizing the first part of the command, which is "dfu-programmer".  I think that the atmega16u2 may not be visible because I am using an unpatched version of dfu-programmer somehow.  Should I attempt to reinstall?

nueh

If you used the package I provided, dfu-programmer should have been installed to '/usr/local/bin'.
Try to invoke it using the full path:
Code: [Select]
sudo /usr/local/bin/dfu-programmer atmega16u2 erase

Ender_sD

#12
Dec 02, 2012, 08:36 pm Last Edit: Dec 02, 2012, 10:44 pm by Ender_sD Reason: 1
I downloaded the file you attached to my desktop and ran the .config from there.

This is how I tried to run what you suggested (I wanted to make sure these were directories as I went along):

Code: [Select]
Adam-Rolphs-iMac-3:~ adamrolph$ /usr
-bash: /usr: is a directory
Adam-Rolphs-iMac-3:~ adamrolph$ /usr/local
-bash: /usr/local: is a directory
Adam-Rolphs-iMac-3:~ adamrolph$ /usr/local/bin
-bash: /usr/local/bin: is a directory
Adam-Rolphs-iMac-3:~ adamrolph$ /usr/local/bin/dfu-programmer
-bash: /usr/local/bin/dfu-programmer: No such file or directory


Obviously something is wrong there.

But, I took what you said and tried running it from where I think I installed it and this is what I got:

Code: [Select]
Adam-Rolphs-iMac-3:~ adamrolph$ /Users/adamrolph/Desktop/DFU/dfu_programmer_install/dfu-programmer
-bash: /Users/adamrolph/Desktop/DFU/dfu_programmer_install/dfu-programmer: is a directory
Adam-Rolphs-iMac-3:~ adamrolph$ sudo /Users/adamrolph/Desktop/DFU/dfu_programmer_install/dfu-programmer atmega16u2 erase
sudo: /Users/adamrolph/Desktop/DFU/dfu_programmer_install/dfu-programmer: command not found



I also tried creating a new directory, redownloading the patch you attached, and installing from there, but after I get to the actual dfu-programmer part of the file directory, it's saying the directory I created doesn't  exist even though I am copy pasting the directory of the newly downloaded dfu-programmer from the "get info" tab

nueh

Oh boy.

Installation:
- In Terminal navigate to your dfu_programmer_install directory.

Not /Users/adamrolph/Desktop/DFU/dfu_programmer_install/dfu-programmer but /Users/adamrolph/Desktop/DFU/dfu_programmer_install

This means type 'cd /Users/adamrolph/Desktop/DFU/dfu_programmer_install'

- Type: ./install_dfu_programmer.sh
Type DOT SLASH install_dfu_programmer.sh

- This executes the install.
- You will be prompted for your password. Type in your password.
- If the install is sucessful you should see the dfu-programmer
manual
- press 'q' to exit the manual.

Try to start the program:
/usr/local/bin/dfu-programmer

See if the output contains 'atmega16u2'

Ender_sD

hahaha it worked.  that firmware didn't know what hit it.  ITS GONE.  erased.

Watch me take over the world by creating sick USB interfaces.  PEACE

thank you nueh

Go Up