Go Down

Topic: ArduinoISP Arduino uno & blank atmega8 bootloader burn trouble (Read 8 times) previous topic - next topic

Nick Gammon

Quote
... im gonna give this a fair shake and read in detail as a favor to myself to atleast give one more chance ...


Good work. I made up that sketch because I wanted to be able to program without all those annoying messages from avrdude.

I warn you that I don't have an Atmega8 (I might order one) so that isn't actually tested with one. It did work with all the other chips I tried in the post.

However at the very least it should report the chip signature, like this:

Code: [Select]

Atmega chip programmer.
Written by Nick Gammon.
Entered programming mode OK.
Signature = 0x1E 0x95 0x0F
Processor = ATmega328P
Flash memory size = 32768 bytes.
LFuse = 0xFF
HFuse = 0xDE
EFuse = 0xFD
Lock byte = 0xCF
Bootloader address = 0x7E00
Bootloader length = 512 bytes.


(Of course yours will be a different signature).

That will prove that you can "talk" to the chip, and that your wires are around the right way etc.

These messages appear in the Serial Monitor so make sure you turn that on after uploading the sketch, and set it to 115200 baud.

I believe I incorporated the correct bootloader into the sketch, as someone else had asked about it a while back.

simplex

#31
Nov 25, 2012, 10:29 pm Last Edit: Nov 25, 2012, 10:32 pm by simplex Reason: 1
Quote from: mysteredding

because i was looking for arduinoisp error fixes not a whole new method of use, when i get done with this other tutorial if it doesnt work i'll give yours a look and try again

This is a completely different story. You should have told it from the beginning.

mysteredding



im gonna be hella mad if it doesnt work

Likely microcontrollers and electronics in general are not for you.
It is self evident you have not read any help page from the beginning to the end. You do not have enough patience.
apparently you have never met me and therefore dont know me so dont go making an assumption about me thats obviously wrong, ive been repairing electronics for YEARS and working with arduino for only 1 so im still very new to it, but if you arent gonna give help and just criticize then dont post again

Nick Gammon

You shouldn't need a crystal, by the way.

Just as a heads-up, I think those chips are usually shipped to run off the internal 8 MHz oscillator, with the "divide clock by 8" fuse set. My programmer should work OK, I've used it with other "fresh" chips, but you might find you need to alter the fuse to get it up to full speed (once you have the bootloader on it). If you don't, it will be running at the wrong baud rate and the bootloader will appear not to be working.

mysteredding


I warn you that I don't have an Atmega8 (I might order one) so that isn't actually tested with one. It did work with all the other chips I tried in the post.
i had noticed tho your tutorial doesnt incorporate completely blank(no-bootloader) bare(no-crystal) microcontrollers, have you tried it that way to see if itll work? im trying to get as much info on this as i can before i try it

Go Up