Go Down

Topic: Arduino MEGA 2560 R2 getting hot in few seconds (Read 623 times) previous topic - next topic

harinath

Nov 28, 2012, 04:58 am Last Edit: Nov 28, 2012, 05:02 am by harinath Reason: 1
Hello arduino tech support,

Arduino MEGA 2560 R2 getting hot in few seconds after plugging USB or AC-DC power adapter.
The microcontroller is getting hot then the heat spreading entire board. Nothing connected to board.
First , When the board connected via USB, drivers installed & board recognized by PC. Getting hot.
Next, I disconnected USB & connected power(center-positive plug) from AC-DC adapter(8.75 V). It is getting hot as usual.
Don't know what to do ?

We bought this board in South Korea. Letters on board shows "MADE IN ITALY".

spycatcher2k

Hi - If you did not buy it from a reseller - it's probably a clone - I've seen this way to many times - Faulty Mega2560 chips, solder bridges, unreliable caps & resisters. Better to get an Official one - They cost a little more, but there tend to be a very few issues with them. and official distributors will tend to replace them if sold faulty.
Drew.
http://www.uk-pcb.co.uk - My UK Based PCB Fab & Assembly Company
Design work undertaken
SMD & Thru-Hole assembly

harinath

I bought it long time ago from http://artrobot.co.kr/. Due to some other project works, i did not test it just after arrival. Now this is the problem. check out this website has dealership for Arduino official hardware.

CrossRoads

Usually a chip that gets really hot has damaged IO pins, and is just a matter of time until total failure (unless it has already).
Designing & building electrical circuits for over 25 years.  Screw Shield for Mega/Due/Uno,  Bobuino with ATMega1284P, & other '328P & '1284P creations & offerings at  my website.

Go Up