Go Down

Topic: burn bootloader to mega 2560 with and UNO ISP (SOLVED) (Read 6855 times) previous topic - next topic

Jul 10, 2012, 06:05 pm Last Edit: Jul 10, 2012, 08:40 pm by MortensenC Reason: 1
Hi,

im going to install a bootloader to an arduino mega 2560 with arduino UNO as ISP.
I follow this steps: http://arduino.cc/en/Tutorial/ArduinoISP
and doesnt work for me

but i see in the sketch this lines:
// pin name:    not-mega:         mega(1280 and 2560)
// slave reset: 10:               53
// MOSI:        11:               51
// MISO:        12:               50
// SCK:         13:               52


and now i want to know, which of the next images is right wired?
1-

2-


Thanks

CrossRoads

See this link also, NickGammon's method lets the entire memory be used.

http://www.gammon.com.au/forum/?id=11635
Designing & building electrical circuits for over 25 years.  Screw Shield for Mega/Due/Uno,  Bobuino with ATMega1284P, & other '328P & '1284P creations & offerings at  my website.

#2
Jul 10, 2012, 07:40 pm Last Edit: Jul 10, 2012, 07:45 pm by MortensenC Reason: 1
thanks CrossRoads it solves my problem!!!

the solution is the picture 1 but the reset is not pin53 is just reset pin, plus the perfect software in the link: http://www.gammon.com.au/forum/?id=11635


what do you mean by "but the reset is not pin53 is just reset pin"??
and i want to program atmega 2560 for my interface board can i do it the same way on the interface board??

Go Up
 


Please enter a valid email to subscribe

Confirm your email address

We need to confirm your email address.
To complete the subscription, please click the link in the email we just sent you.

Thank you for subscribing!

Arduino
via Egeo 16
Torino, 10131
Italy