Go Down

Topic: motori stepper harddisk e ponte H L293 (Read 1 time) previous topic - next topic

chry2000

ciao a tutti ieri mi è arrivato il ponte H (L293) e ho iniziato a fare delle prove con dei motori passo passo normali e funzionavano perfettamente poi ho provato con uno stepper degli HDD a 4 fili e quando ho acceso tutto lo stepper consumava circa 2A e L293 ha iniziato a scaldare tantissimo (per fortuna è ancora vivo) ed ho staccato subito l alimentazione però il motore girava
la mia domanda è per farlo girare senza surriscaldare L293 devo usare delle coppie di transistor NPN e PNP?? siccome da quanto ho capito un ponte H cambia anche polarità ed inoltre è normale che consumino cosi tanto gli stepper degli HDD????

flz47655

Possibili cause:
- hai collegato male il passo passo
- Il passo passo assorbe troppo per il L293 che ha un massimo di 600mA

Possibili soluzioni
- controlla i collegamenti
- puoi mettere in parallelo più uscite/L293 per gestire correnti maggiori (http://electronics.stackexchange.com/questions/23702/can-i-wire-the-two-sides-of-a-l293d-dual-h-bridge-together-if-i-only-need-one-h)

Ciao

flz47655

Se è di un hard disk al 99% è un brushless, ti consiglio di lasciare perdere per non giocarti il tuo IC per il momento

chry2000

molto sicuramente è brushless! avevo letto che ogni canale del l293 riesce ad erogare 600mA non tutti i canali assieme
adesso guardo con il tester i cavi delle bobine

uwefed

Il motore del pacco dischi di un HD non é un stepper ma un brushless con 3 avvolgimenti collegati in stella ( 1 comune e 3 fasi).
Per pilotare quelli ci sono integrati apositi. Li trovi sulla scheda del HD.

Ciao Uwe

chry2000

questo qua va bene? http://www.eleccircuit.com/dc-motor-driver-with-l6203/

uwefed

No.
é per un motore DC con spazzole.

chry2000

ah.. ma esiste un integrato normale e NON SMD per pilotare sti motori siccome sugli hdd sono tutti smd :(



ciao a tutti ieri mi è arrivato il ponte H (L293) e ho iniziato a fare delle prove con dei motori passo passo normali e funzionavano perfettamente poi ho provato con uno stepper degli HDD a 4 fili e quando ho acceso tutto lo stepper consumava circa 2A e L293 ha iniziato a scaldare tantissimo (per fortuna è ancora vivo) ed ho staccato subito l alimentazione però il motore girava
la mia domanda è per farlo girare senza surriscaldare L293 devo usare delle coppie di transistor NPN e PNP?? siccome da quanto ho capito un ponte H cambia anche polarità ed inoltre è normale che consumino cosi tanto gli stepper degli HDD????


Ciao scusa l'intrusione, io sono in possesso dell'l293d e di un brushless a quattro poli. potresti darmi qualche dritta per pm? non capisco come devo comportarmi con i poli del motorino

Go Up
 


Please enter a valid email to subscribe

Confirm your email address

We need to confirm your email address.
To complete the subscription, please click the link in the email we just sent you.

Thank you for subscribing!

Arduino
via Egeo 16
Torino, 10131
Italy