Pages: [1]   Go Down
Author Topic: Trasmittente/ricevente 433mhz  (Read 881 times)
0 Members and 1 Guest are viewing this topic.
Offline Offline
Jr. Member
**
Karma: 0
Posts: 90
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

salve a tutti, avevo comprato questi classici e economici moduli per costruire un antifurto tempo fa


ora, avevo abbandonato temporaneamente la costruzione dell' antifurto, e attualmente stava facendo degli esperimenti di trasmissione-ricezione con questi moduli, e mi sono accorto che non funzionano...
per trasmettere e ricevere stavo utilizzando la libreria virtualwire che è fatta apposta, però, lanciando uno sketch con analogread del sensore, mi sono accorto che il ricevitore, generando dei segnali con un telecomando funziona, ma il trasmettitore non ne vuole sapere di andare... gli ho anche dato degli impulsi da 10microsec ma non vedo niente sul ricevitore... è rotto o sbaglio io??? cosa si può essere rotto???

grazie a tutti per le risposte
Logged

Dueville (VI)
Offline Offline
Edison Member
*
Karma: 28
Posts: 1745
http://cesarecacitti.wordpress.com/
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

Ciao, anche io ho gli stessi moduli, ero riuscito ad utilizzarli usando la libreria offerta da www.electrodragon.com (non riesco adarti il link esatto perché sto usando il cellulare).
Spero che tu riesca a finire il tuo progetto smiley-wink.
Ciao
Cesare
Logged

Arduino UNO r3, Arduino MEGA 1280, adafruit motor shield, bluetooth module, enc28j60 shield.
Ultimi acquisti: un sacco di componenti elettronici, ATTEN AT 8586

Offline Offline
Jr. Member
**
Karma: 0
Posts: 90
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Ciao, anche io ho gli stessi moduli, ero riuscito ad utilizzarli usando la libreria offerta da www.electrodragon.com (non riesco adarti il link esatto perché sto usando il cellulare).
Spero che tu riesca a finire il tuo progetto smiley-wink.
Ciao
Cesare

si, mi ricordo di te... avevo letto un tuo post tempo fa smiley

comunque provo subito immediatamente la libreria, e spero che funzioni... altrimenti è proprio il trasmettitore che è andato smiley-sad
Logged

Monselice PD Italy
Offline Offline
Faraday Member
**
Karma: 26
Posts: 5492
фон Крыса
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Io uso la virtual wire con quei trasmettitori ma finche li ho sulla BB funziona tutto, l'altro giorno monto lo standalone e provo non funziona più nulla, verifico con l'oscilloscopio il segnale che esce dal micro ed è ok, monto le antenne accordate per funzionare a quella frequenza e a distanza di 30cm con alimentazioni separate funziona tutto se li metto più distanti non va nulla... io ho cestinato tutto...  smiley-roll-sweat
Logged

Se corri veloce come un fulmine, ti schianterai come un tuono.

Offline Offline
Jr. Member
**
Karma: 0
Posts: 90
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Io uso la virtual wire con quei trasmettitori ma finche li ho sulla BB funziona tutto, l'altro giorno monto lo standalone e provo non funziona più nulla, verifico con l'oscilloscopio il segnale che esce dal micro ed è ok, monto le antenne accordate per funzionare a quella frequenza e a distanza di 30cm con alimentazioni separate funziona tutto se li metto più distanti non va nulla... io ho cestinato tutto...  smiley-roll-sweat

ho appena visto che la libreria che ti da electrodragon è appunto la virtualwire che è quella con cui ho anche io fatto le prove...

anche a me il segnale che esce dal micro è ok...domani vedo a scuola se riesco a trovare qualcosa che arrivi a misurare 433mhz...

questi qua dovrebbero avere l' antenna integerata, e la trasmissione, va da 10m a 3.8V a circa 150m a 12V... TEORICAMENTE
domani provo a vedere, spero sia rotto qualcosa di stupido tipo il quarzo
Logged

Monselice PD Italy
Offline Offline
Faraday Member
**
Karma: 26
Posts: 5492
фон Крыса
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Non credo abbiate oscilloscopi da 450MHz, costano migliaia di euro xD
e comunque non devi verificare il segnale che esce dall'antenna ma quello che va dal micro al pin ADAT, ed è un segnale a frequenza bassa dovrebbe essere inferiore ai 30khz, ora non ricordo con che temporizzazione campionavo...
Logged

Se corri veloce come un fulmine, ti schianterai come un tuono.

Offline Offline
Jr. Member
**
Karma: 0
Posts: 90
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Non credo abbiate oscilloscopi da 450MHz, costano migliaia di euro xD
e comunque non devi verificare il segnale che esce dall'antenna ma quello che va dal micro al pin ADAT, ed è un segnale a frequenza bassa dovrebbe essere inferiore ai 30khz, ora non ricordo con che temporizzazione campionavo...

no, ovvio che non abbiamo oscilloscopi così  smiley-sweat smiley-sweat smiley-sweat.......................... almeno spero  smiley-eek


magari non so se si fa qualcosa con l' analizzatore di spettro o comunque con l' apparecchiatura da radioamatore, sintonizzandosi sui 433 dovrebbe sentirsi qualche cosa no???

ti dico, il segnale arriva bene, perchè ho analizzato l' impulso e c'è (ho provato sia mentre trasmetteva, e sia generando io un impulso da 10micro)...

semmai domani chiedo al prof di tele

TANTO C'E' AUTOGESTIONE smiley-razz
Logged

Capo d'Orlando
Offline Offline
God Member
*****
Karma: 1
Posts: 560
Electronics & Web Dev, Unix User, Ω LEO, Rock/Deep Music, Tech/Science/Finance addicted, Ski/Snowboard and much more …
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

Un mio amico usò questa guida: http://giltesa.com/2012/07/19/modulos-de-radio-frecuencia-a-433mhz-para-arduino/#more-11606 purtroppo è in spagnolo, però qualcosa si capisce !  smiley-cool
Logged


Pages: [1]   Go Up
Jump to: