Go Down

Topic: Robot doesn't work (Read 2581 times) previous topic - next topic

jeffmorris

I tried to follow the instructions at http://www.instructables.com/id/DFRobotShop-Rover-wXbee/ but the robot doesn't work. I'm using Parallax BOE-BOT with Arduino board instead of BASIC Stamp board. The serial monitor connected to the robot board can read input from the joystick board. The BOE-BOT uses servos instead of DC motors and motor driver. Are there any instructions on using Arduino, XBee, joystick, and servos, or Arduino, XBee, joystick, motors, and motor driver?

oric_dan

You've built a totally different robot from the one shown in your link, using a completely
different set of parts, and you wonder why it doesn't work.

And on top of that, you've not even looked at the dozens of descriptions of how to use
the following devices on the main Arduino site and Playground,

Quote

Are there any instructions on using Arduino, XBee, joystick, and servos, or Arduino, XBee, joystick, motors, and motor driver?


What's wrong with this picture?

jeffmorris

I have been searching the Internet for instructions on using Arduino, XBee, joystick, and servos, or Arduino, XBee, joystick, motors, and motor driver but videos don't have captioning and I'm hearing-impaired.

codlink

I doubt that any tutorials will have all those things in one.  Try the tutorials for each item, then slowly bring them together.  There are tons of tutorials in text.
//LiNK

oric_dan

Quote
videos don't have captioning


Personally, I don't find many videos to be all that helpful. You need to go to pages
with text on them to get detailed info. Besides going to the main Arduino site and
Playground, as mentioned, it might be quicker to just do a google search on each
item on the list, paired with Arduino, eg search "Arduino XBee", on and on.

http://www.google.com/webhp?source=search_app#hl=en&gs_id=11&xhr=t&q=arduino+xbee&fp=7af77d91003207f5

zoomkat

In my sig below are instructions on how to do a google search of this forum for your key words of interest.
Google forum search: Use Google Advanced Search and use Http://forum.arduino.cc/index in the "site or domain:" box.

jeffmorris

I think that I got the robot working following the instructions in "Arduino Remote Control Robot" article in November 2012 issue of Servo Magazine but the project called for a five-position switch which I don't have. I used five push buttons and resistors. I don't know if the five-position switch have resistors.

oric_dan

I looked at the Servo mag article. It says "Each of the five switches has it's own
pullup resistor". You're ok with the pushbutton switches, the 5-pos device is just
more compact.

Go Up