Go Down

Topic: UTFT not working in IDE 1.6.5 but works perfectly in IDE 1.5.4 (Read 279 times) previous topic - next topic

rolfmeurer

/*
IDE 1.5.4 works fine but IDE 1.6.5 'NO TFT sceen at all':

ARDUINO DUE with
CTE TFT LCD/SD Shield for ARDUINO DUE
SainSmart 2.8 inch 240x320 TFT shield CTE28

Oscilloscope Test. works only with IDE 1.5.4 but not with 1.6.5
 */

#include <UTFT.h>
// Uncomment the next line for Arduino DUE
UTFT myGLCD(CTE28,25,26,27,28);


uint16_t sample[321];
void setup() {
  myGLCD.InitLCD();
  myGLCD.clrScr();
  myGLCD.setColor(255, 255, 255);
}
void loop() {

  for (uint16_t i = 1; i < 320; i++) {
    sample = analogRead(A0);
  }

  if (sample[319] > 512) {
    myGLCD.clrScr();
    for (uint16_t i = 1; i < 319; i++) {
      myGLCD.drawLine (i, 120 - sample, i + 1, 120 - sample[i + 1]);
    }
  }
}

ghlawrence2000

Learn how to use code tags...... And that code won't even compile..... so I don't see how you can blame UTFT?

Are you using a Sainshit modified version of UTFT or the genuine version? The reason I ask, is I have just downloaded IDE v1.6.5 and it works fine with my existing UTFT v2.81 and CTE DUE shield.

Regards,

Graham
UTFT_SdRaw now included in library manager!! ;) High speed image drawing from SD card to UTFT displays for Mega & DUE.
UTFT_GHL - a VASTLY upgraded version of UTFT_CTE. Coming soon to a TFT near you! 8) Shipping April 1 2016!

rolfmeurer

Long time ago .... I got i work but so Long time ago I can't remeber how.. I guess I made changes in the library.

ghlawrence2000

UTFT_SdRaw now included in library manager!! ;) High speed image drawing from SD card to UTFT displays for Mega & DUE.
UTFT_GHL - a VASTLY upgraded version of UTFT_CTE. Coming soon to a TFT near you! 8) Shipping April 1 2016!

Go Up
 


Please enter a valid email to subscribe

Confirm your email address

We need to confirm your email address.
To complete the subscription, please click the link in the email we just sent you.

Thank you for subscribing!

Arduino
via Egeo 16
Torino, 10131
Italy