Pages: [1]   Go Down
Author Topic: Build folder disappeared or could not be written - Mac OS  (Read 633 times)
0 Members and 1 Guest are viewing this topic.
Offline Offline
Newbie
*
Karma: 0
Posts: 1
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Mac OS X version 10.7.5
Arduino 1.0.3 - installed from zip and put into /Applications
Board: Arduino Uno - R3
Tools > Board > Arduino Uno
Tools > Serial Port > dev/tty.usbmodemfd511

Using any sketch (started w Blink) on attempting to Upload the sketch to the board it get the error:

Build folder disappeared or could not be written
Full error:
Code:
java.io.FileNotFoundException: /var/folders/cq/wh8rvyfd2q563b514tf965_m0000gn/T/build7467485321865395108.tmp/Blink.cpp (No such file or directory)
at java.io.FileOutputStream.open(Native Method)
at java.io.FileOutputStream.<init>(FileOutputStream.java:194)
at java.io.FileOutputStream.<init>(FileOutputStream.java:145)
at processing.app.preproc.PdePreprocessor.writePrefix(PdePreprocessor.java:139)
at processing.app.Sketch.preprocess(Sketch.java:1390)
at processing.app.Sketch.preprocess(Sketch.java:1339)
at processing.app.Sketch.build(Sketch.java:1585)
at processing.app.Sketch.exportApplet(Sketch.java:1613)
at processing.app.Sketch.exportApplet(Sketch.java:1599)
at processing.app.Editor$DefaultExportHandler.run(Editor.java:2380)
at java.lang.Thread.run(Thread.java:680)
processing.app.debug.RunnerException: Build folder disappeared or could not be written
at processing.app.Sketch.preprocess(Sketch.java:1397)
at processing.app.Sketch.preprocess(Sketch.java:1339)
at processing.app.Sketch.build(Sketch.java:1585)
at processing.app.Sketch.exportApplet(Sketch.java:1613)
at processing.app.Sketch.exportApplet(Sketch.java:1599)
at processing.app.Editor$DefaultExportHandler.run(Editor.java:2380)
at java.lang.Thread.run(Thread.java:680)

I have tried several different sketchbook locations (Arduino > Preferences) - all result in same error, and failure to upload the sketch to the board. No blinking tx or rx. My "L" led flashes...

Seems like the app is not respecting my pref for sketchbook.path - or something is whacky about my environment that arduino.app doesn't like...

Previous posts on this were old, didn't provide any clues.
FAQ same... all it suggests is don't run from the .dmg

Also currently the forum's search function is not working.

Does it matter what is chosen for tools > programmer?
Logged

Rome, Italy
Offline Offline
Sr. Member
****
Karma: 20
Posts: 442
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Hi, /var/folders is the location where the IDE copies intermediate files before compiling them. Maybe you don't have write permission on that directory, or on the cq directory under it. I don't think you can change the location but you can change the permissions. As for the programmer I feel safe using AVRISP mkll, which is probably what I got as a default.
Logged

Pages: [1]   Go Up
Jump to: